aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/qprog/Makefile31
-rw-r--r--devel/qprog/distinfo3
-rw-r--r--devel/qprog/pkg-descr8
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ca4d3e0f0ec0..a155c0ae74c0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2023,6 +2023,7 @@
SUBDIR += qt4-script
SUBDIR += qt4-uic
SUBDIR += qt4-uic3
+ SUBDIR += qprog
SUBDIR += qsa
SUBDIR += qscintilla2
SUBDIR += qscintilla2-designerplugin
diff --git a/devel/qprog/Makefile b/devel/qprog/Makefile
new file mode 100644
index 000000000000..1666c65a88ed
--- /dev/null
+++ b/devel/qprog/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: qprog
+# Date created: 2007/07/20
+# Whom: Brandon Fosdick <bfoz@bfoz.net>
+#
+# $FreeBSD$
+
+PORTNAME= qprog
+PORTVERSION= 0.4
+CATEGORIES= devel
+MASTER_SITES= http://bfoz.net/projects/${PORTNAME}/release/
+DISTNAME= QProg_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bfoz@bfoz.net
+COMMENT= Cross-platform software for the DIY line of PIC programmers
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc gui network
+
+WRKSRC= ${WRKDIR}/QProg
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-configure:
+ ( cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} -unix PREFIX=${PREFIX} QProg.pro )
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/qprog/distinfo b/devel/qprog/distinfo
new file mode 100644
index 000000000000..5fd9bebce473
--- /dev/null
+++ b/devel/qprog/distinfo
@@ -0,0 +1,3 @@
+MD5 (QProg_0.4.tgz) = ecbaa34b7e4ec6d3c54c03d24e5c3b93
+SHA256 (QProg_0.4.tgz) = 1ee000642e6a6b14eb6fbbd8b4e18c0aea120724e43c91a8af31a83ee4393ae7
+SIZE (QProg_0.4.tgz) = 43507
diff --git a/devel/qprog/pkg-descr b/devel/qprog/pkg-descr
new file mode 100644
index 000000000000..ace6152208be
--- /dev/null
+++ b/devel/qprog/pkg-descr
@@ -0,0 +1,8 @@
+QProg is an OS X, Windows, and *nix/X11 compatible software interface to the
+popular DIY line of PIC programmers sold by Kitsrus and is intended to be a
+cross-platform replacement for the software provided with the DIY kits.
+
+WWW: http://bfoz.net/projects/qprog/
+
+-Brandon Fosdick
+bfoz@bfoz.net