aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Module-Build/Makefile21
-rw-r--r--devel/p5-Module-Build/distinfo4
-rw-r--r--devel/p5-Module-Build/files/patch-lib::Module::Build::Compat.pm11
-rw-r--r--devel/p5-Module-Build/inc.build.mk14
4 files changed, 21 insertions, 29 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index c9996adfd2e0..5b87af2857ab 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Module-Build
-PORTVERSION= 0.22
+PORTVERSION= 0.23
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Module
@@ -42,6 +42,24 @@ MAN3= Module::Build.3 \
Module::Build::Platform::darwin.3 \
Module::Build::Platform::os2.3
+PERL_CONFIGURE= yes
+CONFIGURE_SCRIPT?= Build.PL
+ALL_TARGET?=
+PL_BUILD?= Build
+CONFIGURE_ARGS+= \
+ install_path=lib="${PREFIX}/${SITE_PERL_REL}" \
+ install_path=arch="${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}" \
+ install_path=script="${PREFIX}/bin" \
+ install_path=bin="${PREFIX}/bin" \
+ install_path=libdoc="${MAN3PREFIX}/man/man3" \
+ install_path=bindoc="${MAN1PREFIX}/man/man1"
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} ${PL_BUILD} ${MAKE_ARGS} ${ALL_TARGET})
+
+do-install:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} ${PL_BUILD} ${MAKE_ARGS} ${INSTALL_TARGET})
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} > 500600
@@ -51,5 +69,4 @@ BUILD_DEPENDS+= ${SITE_PERL}/ExtUtils/ParseXS.pm:${PORTSDIR}/devel/p5-ExtUtils-P
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
-.include "inc.build.mk"
.include <bsd.port.post.mk>
diff --git a/devel/p5-Module-Build/distinfo b/devel/p5-Module-Build/distinfo
index 4a596e249755..be03f2a89586 100644
--- a/devel/p5-Module-Build/distinfo
+++ b/devel/p5-Module-Build/distinfo
@@ -1,2 +1,2 @@
-MD5 (Module-Build-0.22.tar.gz) = a788154750c657d01c0bf97d72e787e2
-SIZE (Module-Build-0.22.tar.gz) = 98397
+MD5 (Module-Build-0.23.tar.gz) = 712d8c3be8afda673acdf83bc82af4b9
+SIZE (Module-Build-0.23.tar.gz) = 100214
diff --git a/devel/p5-Module-Build/files/patch-lib::Module::Build::Compat.pm b/devel/p5-Module-Build/files/patch-lib::Module::Build::Compat.pm
deleted file mode 100644
index 05533a0a68d8..000000000000
--- a/devel/p5-Module-Build/files/patch-lib::Module::Build::Compat.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Module/Build/Compat.pm~ Sun Jan 11 05:19:59 2004
-+++ lib/Module/Build/Compat.pm Tue Jan 13 14:44:22 2004
-@@ -144,7 +144,7 @@
- $perl -e unlink -e shift $makefile
-
- force_do_it :
-- @
-+
- EOF
-
- # XXX - user might be using a different subclass
diff --git a/devel/p5-Module-Build/inc.build.mk b/devel/p5-Module-Build/inc.build.mk
deleted file mode 100644
index e6105348c922..000000000000
--- a/devel/p5-Module-Build/inc.build.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# $FreeBSD$
-# To be used by modules using Module::Build
-
-.if ${PORTNAME} != Module-Build
-BUILD_DEPENDS+= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
-.endif
-
-CONFIGURE_ARGS+= install_path=lib="${SITE_PERL:S|^${LOCALBASE}/|${PREFIX}/|}" \
- install_path=arch="${SITE_PERL:S|^${LOCALBASE}/|${PREFIX}/|}/${PERL_ARCH}" \
- install_path=script="${PREFIX}/bin" \
- install_path=bin="${PREFIX}/bin" \
- install_path=libdoc="${MAN3PREFIX}/man/man3" \
- install_path=bindoc="${MAN1PREFIX}/man/man1"
-