aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/libpafe-ruby/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/libpafe-ruby/Makefile b/devel/libpafe-ruby/Makefile
index 8e5763d80e0c..0357c7dfb39c 100644
--- a/devel/libpafe-ruby/Makefile
+++ b/devel/libpafe-ruby/Makefile
@@ -14,14 +14,17 @@ COMMENT= Ruby binding for libpafe
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= pafe:${PORTSDIR}/devel/libpafe
+LIB_DEPENDS= libpafe.so:${PORTSDIR}/devel/libpafe
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+NEED_ROOT= yes
PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/pasori.so
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
+pre-install:
+ @${MKDIR} ${STAGEDIR}${RUBY_SITEARCHLIBDIR}
+
.include <bsd.port.mk>