aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind912/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/bind912/Makefile')
-rw-r--r--dns/bind912/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/dns/bind912/Makefile b/dns/bind912/Makefile
index 29dc7c2a9da0..e1a80702ed85 100644
--- a/dns/bind912/Makefile
+++ b/dns/bind912/Makefile
@@ -5,10 +5,9 @@ PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
.if defined(BIND_TOOLS_SLAVE)
# dns/bind-tools here
-PORTREVISION= 1
+PORTREVISION= 0
.else
-# dns/bind912 here
-PORTREVISION= 2
+PORTREVISION= 0
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -33,7 +32,7 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
USES= compiler:c11 cpe libedit
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.3
+ISCVERSION= 9.12.3-P1
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -43,7 +42,6 @@ CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
- --disable-symtable \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
--with-readline="-L${LOCALBASE}/lib -ledit" \
@@ -211,6 +209,12 @@ TUNING_LARGE_CONFIGURE_OFF= --with-tuning=default
.include <bsd.port.pre.mk>
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-symtable
+.else
+CONFIGURE_ARGS+= --disable-symtable
+.endif
+
.if ${SSL_DEFAULT} == base
SUB_LIST+= ENGINES=/usr/lib/engines
.else