aboutsummaryrefslogtreecommitdiffstats
path: root/dns/dnsmasq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/dnsmasq/Makefile')
-rw-r--r--dns/dnsmasq/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 37e45e6aab31..4e9bfddfbfa3 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dnsmasq
-PORTVERSION= 2.17
+PORTVERSION= 2.18
CATEGORIES= dns
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/
@@ -14,19 +14,27 @@ MAINTAINER= steven@honson.org
COMMENT= Lightweight, easy to configure DNS forwarder and DHCP server
USE_REINPLACE= yes
+USE_RC_SUBR= yes
MAN8= dnsmasq.8
PLIST_FILES= sbin/dnsmasq etc/dnsmasq.conf.example etc/rc.d/dnsmasq.sh
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|^CC = gcc|CC?=cc|g ; \
- s|^CFLAGS = -O2|CFLAGS+=-O2|g' ${WRKSRC}/Makefile
+USE_GETOPT_LONG= yes
+MAKE_ENV+= "LIBS=${LDFLAGS}"
+.if defined(WITHOUT_IPV6)
+MAKE_ENV+= RPM_OPT_FLAGS="${CPPFLAGS} -DNO_IPV6"
+.else
+MAKE_ENV+= RPM_OPT_FLAGS="${CPPFLAGS}"
+.endif
+
+post-build:
+ @${SED} -e "s|%%RC_SUBR%%|${RC_SUBR}|g;s|%%PREFIX%%|${PREFIX}|g" \
+ <${FILESDIR}/dnsmasq.sh >${WRKDIR}/dnsmasq.sh
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${PREFIX}/etc
- ${INSTALL_SCRIPT} ${FILESDIR}/dnsmasq.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${WRKDIR}/dnsmasq.sh ${PREFIX}/etc/rc.d
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
.include <bsd.port.mk>