aboutsummaryrefslogtreecommitdiffstats
path: root/dns/dnsmasq
diff options
context:
space:
mode:
Diffstat (limited to 'dns/dnsmasq')
-rw-r--r--dns/dnsmasq/Makefile20
-rw-r--r--dns/dnsmasq/distinfo4
-rw-r--r--dns/dnsmasq/files/dnsmasq.sh4
3 files changed, 18 insertions, 10 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 37e45e6aab31..4e9bfddfbfa3 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dnsmasq
-PORTVERSION= 2.17
+PORTVERSION= 2.18
CATEGORIES= dns
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/
@@ -14,19 +14,27 @@ MAINTAINER= steven@honson.org
COMMENT= Lightweight, easy to configure DNS forwarder and DHCP server
USE_REINPLACE= yes
+USE_RC_SUBR= yes
MAN8= dnsmasq.8
PLIST_FILES= sbin/dnsmasq etc/dnsmasq.conf.example etc/rc.d/dnsmasq.sh
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|^CC = gcc|CC?=cc|g ; \
- s|^CFLAGS = -O2|CFLAGS+=-O2|g' ${WRKSRC}/Makefile
+USE_GETOPT_LONG= yes
+MAKE_ENV+= "LIBS=${LDFLAGS}"
+.if defined(WITHOUT_IPV6)
+MAKE_ENV+= RPM_OPT_FLAGS="${CPPFLAGS} -DNO_IPV6"
+.else
+MAKE_ENV+= RPM_OPT_FLAGS="${CPPFLAGS}"
+.endif
+
+post-build:
+ @${SED} -e "s|%%RC_SUBR%%|${RC_SUBR}|g;s|%%PREFIX%%|${PREFIX}|g" \
+ <${FILESDIR}/dnsmasq.sh >${WRKDIR}/dnsmasq.sh
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${PREFIX}/etc
- ${INSTALL_SCRIPT} ${FILESDIR}/dnsmasq.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${WRKDIR}/dnsmasq.sh ${PREFIX}/etc/rc.d
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/dns/dnsmasq/distinfo b/dns/dnsmasq/distinfo
index 413de2904a21..83731d2a860d 100644
--- a/dns/dnsmasq/distinfo
+++ b/dns/dnsmasq/distinfo
@@ -1,2 +1,2 @@
-MD5 (dnsmasq-2.17.tar.gz) = c66ded2740975cf05040934ed4427f6a
-SIZE (dnsmasq-2.17.tar.gz) = 132911
+MD5 (dnsmasq-2.18.tar.gz) = 7a3d4864c97ebf484cd4e76487ad5e3c
+SIZE (dnsmasq-2.18.tar.gz) = 133590
diff --git a/dns/dnsmasq/files/dnsmasq.sh b/dns/dnsmasq/files/dnsmasq.sh
index 529c437715eb..c723b1ec3361 100644
--- a/dns/dnsmasq/files/dnsmasq.sh
+++ b/dns/dnsmasq/files/dnsmasq.sh
@@ -14,12 +14,12 @@
dnsmasq_enable=NO
-. /etc/rc.subr
+. %%RC_SUBR%%
name=dnsmasq
rcvar=$(set_rcvar)
-command=/usr/local/sbin/${name}
+command=%%PREFIX%%/sbin/${name}
pidfile=/var/run/${name}.pid
required_files=${dnsmasq_conf}
#start_precmd=${name}_precmd
eletions'>-8/+8 * Update to 0.15skv2006-11-112-4/+4 * - do not delete Local/Library/Librariesdinoex2006-11-091-1/+0 * - fix package problemsdinoex2006-11-093-9/+648 * - Drop maintainershipmiwi2006-11-091-1/+1 * - Update to 0.612rafan2006-11-092-5/+5 * A very configureable web-gallery generator written in perl with support foralepulver2006-11-095-0/+48 * update to 2.1.4oliver2006-11-092-4/+4 * - Fix recent vulerabilities in imlib2.stas2006-11-098-1/+224 * Remove CONFLICTS=linux-gtk2*bsam2006-11-083-6/+0 * Deprecate port. Will be removed on 25th of December 2006.flz2006-11-081-0/+3 * - Update WWW and MASTER_SITESmiwi2006-11-082-2/+2 * Fix package buildingjylefort2006-11-086-3/+18 * - Mark broken on 4.xsat2006-11-081-1/+7 * Upgrade to CImg v.1.1.7.thierry2006-11-075-13/+102 * Now that I've added graphics/linux-libGLU, fix the libGLU dependencyjylefort2006-11-061-3/+5 * Conflicts with linux-libGLUjylefort2006-11-062-2/+2 * Add linux-libGLU.so. Unlike graphics/linux_dri, this port does notjylefort2006-11-067-0/+85 * - Fix building with GCC 4.1 [1].alepulver2006-11-062-1/+25 * - Mark for removal in 2 months (No new releases in the past 4 years)miwi2006-11-051-1/+4 * Update master site and WWW.lawrance2006-11-052-2/+2 * INSTALLS_SHLIB -> USE_LDCONFIG.mezz2006-11-054-4/+4 * Mark IGNORE on 4.X as it does not build.mezz2006-11-052-0/+8 * Update to 1.0.6ahze2006-11-053-11/+11 * Update to 3.6.1.mezz2006-11-042-6/+5 * Update to 2.16.1ahze2006-11-032-5/+4 * Drop maintainershipjylefort2006-11-031-1/+1 * Update to 1.2.6ahze2006-11-032-4/+4 * - Update to 1.01ahze2006-11-032-4/+4 * Update to 2.16.1.1.marcus2006-11-033-7/+73 * - Pass maintainer to submittermiwi2006-11-021-1/+1 * - Update to 1.13clsung2006-11-022-4/+4 * - Update to 0.3clsung2006-11-022-5/+7 * - Update to 1.14.1stas2006-11-023-7/+12 * - Update to 0.10sat2006-11-023-32/+43 * - Follow PECL ports naming conversionleeym2006-11-016-102/+0 * - Fix mastersite.jmelo2006-11-011-1/+1 * - add pecl-imlib2 0.1.00leeym2006-11-015-0/+84 * - Update to 2.0.2 releaseale2006-11-013-6/+32 * - Pass maintainership to submittermiwi2006-11-011-1/+1 * - Update to 0.0.20061022rafan2006-11-013-17/+9 * Update to 1.0.1.lawrance2006-11-014-56/+62 * - Update to 0.8.0sat2006-11-012-5/+6 * - Update to 8.41sat2006-11-012-4/+4 * update to 2.1.2oliver2006-10-313-5/+8 * - Update to 0.4.0miwi2006-10-314-16/+20 * - update to 10.26.33dinoex2006-10-312-4/+4 * - cleanup dirs that are now in gnustep-makedinoex2006-10-311-0/+1 * - update to 10.26.32dinoex2006-10-312-4/+4 * - drop USE_X_PREFIXdinoex2006-10-311-1/+1 * - Update to version 3.01.alepulver2006-10-313-10/+7 * Update MASTER_SITES and make it fetchable againehaupt2006-10-281-16/+2 * - Fix pkg-plist and unbreakmarkus2006-10-256-6/+74 * - Fix display of RAW imagesmarkus2006-10-244-6/+24 * - Fix a startup crash for anyone running non-latin-1 localepav2006-10-234-2/+40 * Add NO_LATEST_LINK to avoid conflict with graphics/gimp.marcus2006-10-222-0/+2 * - Unbreak on system < 7.x by using malloc(3)rafan2006-10-214-30/+40 * BROKEN: Does not buildkris2006-10-211-0/+2 * Use INST_TARGET instead of TARGETDIR locally to avoid conflictingerwin2006-10-171-5/+5 * - install all needed share libsitetcu2006-10-163-12/+6 * Fix the build on 4.X.marcus2006-10-161-0/+14 * - Readd gimp-develahze2006-10-1417-0/+5025 * - Add py-goocanvasahze2006-10-144-0/+43 * Chase the GNOME X11BASE to LOCALBASE move, and fix the build with themarcus2006-10-1475-391/+1189 * - Add goocanvasahze2006-10-145-0/+97 * Presenting GNOME 2.16.1 for FreeBSD. This release represents a massivemarcus2006-10-1429