aboutsummaryrefslogtreecommitdiffstats
path: root/dns/fastresolve/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/fastresolve/Makefile')
-rw-r--r--dns/fastresolve/Makefile37
1 files changed, 15 insertions, 22 deletions
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index 785fa92a9d33..9c9515a23f5d 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -10,38 +10,31 @@ MASTER_SITES= http://www.djmnet.org/sw/dist/
MAINTAINER= ports@FreeBSD.org
COMMENT= Programs that process web logs to get DNS and domain ownership info
-LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
+LIB_DEPENDS= libadns.so:${PORTSDIR}/dns/adns
RUN_DEPENDS= p5-BerkeleyDB>=0:${PORTSDIR}/databases/p5-BerkeleyDB
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS_DEFINE= DOCS
USES= perl5
+USE_BDB= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PERL=${PERL}
-LDFLAGS+= -L${LOCALBASE}/lib
-CXXFLAGS+= -I${LOCALBASE}/include
-USE_AUTOTOOLS= aclocal14 automake14 autoconf213
-
-USE_BDB= yes
-CONFIGURE_ARGS= --with-bdb-lib=-l${BDB_LIB_CXX_NAME} --with-bdb-incdir=${BDB_INCLUDE_DIR}
-
-MAN1= dns-terror.1 btree-dump.1 convert-dom-db.1 convert-ip-db.1 \
- expire-ip-db.1 getdominfo.1 rebuild-dom-db.1 rebuild-ip-db.1 \
- reresolve.1 make-report.1
+CONFIGURE_ENV= PERL=${PERL} \
+ djm_cv_lib_db_Dbopen=yes
+LDFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
+CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's/-ldb"/-ldb -l${BDB_LIB_CXX_NAME}"/g' ${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in AUTHORS COPYING ChangeLog INSTALL NEWS README
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
- @${INSTALL_DATA} ${WRKSRC}/doc/TODO ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/timings ${DOCSDIR}
-.endif
+ @${INSTALL_DATA} ${WRKSRC}/doc/TODO ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/timings ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>