aboutsummaryrefslogtreecommitdiffstats
path: root/dns/idnkit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/idnkit/Makefile')
-rw-r--r--dns/idnkit/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/dns/idnkit/Makefile b/dns/idnkit/Makefile
index 23ef9d8f3b76..cf7586068010 100644
--- a/dns/idnkit/Makefile
+++ b/dns/idnkit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= idnkit
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns
MASTER_SITES= http://www.nic.ad.jp/ja/idn/idnkit/download/sources/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A library to handle internationalized domain names
USE_ICONV= yes
-USE_AUTOTOOLS= libtool:13:inc
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv=${LOCALBASE} \
--enable-runidn \
@@ -36,6 +36,10 @@ MANCOMPRESSED= no
DOCS_EN= ChangeLog NEWS README
DOCS_JA= README.ja
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|mode=link $$(LD)|mode=link $$(CC)|'
+
post-install:
${INSTALL_DATA} ${WRKSRC}/tools/runidn/libidnkitres.la ${PREFIX}/lib
.if !defined(NOPORTDOCS)