aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-Net-DNS/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/p5-Net-DNS/Makefile')
-rw-r--r--dns/p5-Net-DNS/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/dns/p5-Net-DNS/Makefile b/dns/p5-Net-DNS/Makefile
index f156f84c6f3f..210e4c780390 100644
--- a/dns/p5-Net-DNS/Makefile
+++ b/dns/p5-Net-DNS/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-DNS
-PORTVERSION= 0.53
+PORTVERSION= 0.54
CATEGORIES= dns net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
@@ -16,8 +16,7 @@ MAINTAINER= DougB@FreeBSD.org
COMMENT= Perl5 interface to the DNS resolver, and dynamic updates
# Warnings during build are harmless, the port does not need these to build
-RUN_DEPENDS= ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ipcount:${PORTSDIR}/net-mgmt/p5-Net-IP
+RUN_DEPENDS= ipcount:${PORTSDIR}/net-mgmt/p5-Net-IP
PERL_CONFIGURE= yes
CONFIGURE_ARGS+= --online-tests
@@ -44,11 +43,23 @@ MAN3= Net::DNS.3 Net::DNS::Header.3 Net::DNS::Packet.3 \
.include <bsd.port.pre.mk>
+pre-fetch:
+.if ${PERL_LEVEL} < 500600
+ @${ECHO} "************************************************************"
+ @${ECHO} "* WARNING: Dependencies for the cryptographic functions of *"
+ @${ECHO} "* this library require at least Perl 5.6.2. Although most *"
+ @${ECHO} "* functions of this library will work without them, if you *"
+ @${ECHO} "* need those features, you will have to upgrade Perl. *"
+ @${ECHO} "************************************************************"
+ @sleep 5
+.else
+RUN_DEPENDS= ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC
+.endif
+
.if ${PERL_LEVEL} < 500800
.if defined(WITH_IPv6)
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-INET6
.endif
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
PLIST_SUB+= BYTES_INSTALL=""
.else
PLIST_SUB+= BYTES_INSTALL="@comment "