aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-Net-Domain-ExpireDate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/p5-Net-Domain-ExpireDate/Makefile')
-rw-r--r--dns/p5-Net-Domain-ExpireDate/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/dns/p5-Net-Domain-ExpireDate/Makefile b/dns/p5-Net-Domain-ExpireDate/Makefile
index 05e9daa5f666..387334b623e6 100644
--- a/dns/p5-Net-Domain-ExpireDate/Makefile
+++ b/dns/p5-Net-Domain-ExpireDate/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-Domain-ExpireDate
-PORTVERSION= 0.98
+PORTVERSION= 1.00
CATEGORIES= dns net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,10 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Perl module obtain expiration date of domain names
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece \
- ${SITE_PERL}/Net/Whois/Raw.pm:${PORTSDIR}/net/p5-Net-Whois-Raw \
- ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${SITE_PERL}/Net/Whois/Raw.pm:${PORTSDIR}/net/p5-Net-Whois-Raw
PERL_CONFIGURE= yes
@@ -26,4 +23,10 @@ MAN3= Net::Domain::ExpireDate.3
post-patch:
@${FIND} ${WRKSRC} -name "*.orig" -delete
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500905
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
+.endif
+
+.include <bsd.port.post.mk>