aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/bind99/Makefile19
-rw-r--r--dns/bind99/distinfo8
-rw-r--r--dns/bind99/files/named.conf.in10
-rw-r--r--dns/bind99/files/patch-bin__dnssec__Makefile.in17
-rw-r--r--dns/bind99/files/patch-bin__python__Makefile.in13
-rw-r--r--dns/bind99/files/patch-configure25
-rw-r--r--dns/bind99/pkg-plist52
7 files changed, 54 insertions, 90 deletions
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 80385acbba1b..ea90818c1db0 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -2,7 +2,6 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/}
-PORTREVISION= 5
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 99
@@ -14,7 +13,7 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= ISCL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.9.5-P1
+ISCVERSION= 9.9.6
MAKE_JOBS_UNSAFE= yes
@@ -98,8 +97,7 @@ FILTER_AAAA_CONFIGURE_ENABLE= filter-aaaa
GOST_CONFIGURE_WITH= gost
PYTHON_CONFIGURE_WITH= python
-PYTHON_USE= PYTHON=yes
-PYTHON_USES= gmake
+PYTHON_USES= python
DLZ_POSTGRESQL_CONFIGURE_ON= --with-dlz-postgres=yes
DLZ_POSTGRESQL_USE= pgsql=yes
@@ -110,7 +108,7 @@ RPZ_NSIP_CONFIGURE_ENABLE= rpz-nsip
RPZ_NSDNAME_CONFIGURE_ENABLE= rpz-nsdname
-RPZ_PATCH_PATCHFILES= 9.9.5-P1-rpz2+rl.14038.05.patch:vix
+RPZ_PATCH_PATCHFILES= 9.9.6-rpz2+rl.14038.05.patch:vix
RPZ_PATCH_PATCH_SITES= http://ss.vix.su/~vjs/:vix ${MASTER_SITE_LOCAL:S/%SUBDIR%/mat\/bind/:S/$/:vix/}
RRL_CONFIGURE_ENABLE= rrl
@@ -176,6 +174,8 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} \
--sysconfdir=${BIND_DESTETC}
SUB_LIST+= BIND_DESTETC="${BIND_DESTETC}"
+PORTDOCS= *
+
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100
PLIST_SUB+= NOBASE="" BASE="@comment "
USE_RC_SUBR+= named
@@ -207,15 +207,14 @@ post-patch:
${WRKSRC}/bin/named/Makefile.in.Dist > \
${WRKSRC}/bin/named/Makefile.in
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-.endif
+post-configure:
+ @${REINPLACE_CMD} -e '/^SO_LDFLAGS/s/-Wl,-rpath,/-rpath /' ${WRKSRC}/bin/tests/system/dlzexternal/Makefile
+
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/arm ${STAGEDIR}${DOCSDIR}/misc
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/arm
${INSTALL_DATA} ${WRKSRC}/doc/arm/*.html ${STAGEDIR}${DOCSDIR}/arm
${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM.pdf ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* ${STAGEDIR}${DOCSDIR}/misc
${INSTALL_DATA} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ \
${WRKSRC}/HISTORY ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
diff --git a/dns/bind99/distinfo b/dns/bind99/distinfo
index bfb85e28602a..3391c07fe195 100644
--- a/dns/bind99/distinfo
+++ b/dns/bind99/distinfo
@@ -1,4 +1,4 @@
-SHA256 (bind-9.9.5-P1.tar.gz) = a41f7813f3a6eb0dcae961651ec93896fd82074929bc6c1d8c90b04a2417b850
-SIZE (bind-9.9.5-P1.tar.gz) = 7730150
-SHA256 (9.9.5-P1-rpz2+rl.14038.05.patch) = 48110f1f0b5c27d2fe3230888f69fdd175f8d0db54f64f73c03449f5ba8ec88a
-SIZE (9.9.5-P1-rpz2+rl.14038.05.patch) = 238941
+SHA256 (bind-9.9.6.tar.gz) = 6b9432644a3bfa41695354543bd9e2547104e35f3c7354a416a030a4cdd1c514
+SIZE (bind-9.9.6.tar.gz) = 7811896
+SHA256 (9.9.6-rpz2+rl.14038.05.patch) = 7ff0f755a032f6c44ed5758c257a8e217be8e7f8af5bf967333e08621b1abe67
+SIZE (9.9.6-rpz2+rl.14038.05.patch) = 194775
diff --git a/dns/bind99/files/named.conf.in b/dns/bind99/files/named.conf.in
index 6c3215883552..d8bb64d741e7 100644
--- a/dns/bind99/files/named.conf.in
+++ b/dns/bind99/files/named.conf.in
@@ -52,7 +52,7 @@ options {
// the entries in /etc/resolv.conf, uncomment the following line and
// set named_auto_forward=yes in /etc/rc.conf. You can also enable
// named_auto_forward_only (the effect of which is described above).
-// include "/etc/namedb/auto_forward.conf";
+// include "%%BIND_DESTETC%%/auto_forward.conf";
/*
Modern versions of BIND use a random UDP port for each outgoing
@@ -100,7 +100,7 @@ zone "." { type hint; file "%%BIND_DESTETC%%/named.root"; };
/*
zone "." {
type slave;
- file "/etc/namedb/slave/root.slave";
+ file "%%BIND_DESTETC%%/slave/root.slave";
masters {
192.5.5.241; // F.ROOT-SERVERS.NET.
};
@@ -108,7 +108,7 @@ zone "." {
};
zone "arpa" {
type slave;
- file "/etc/namedb/slave/arpa.slave";
+ file "%%BIND_DESTETC%%/slave/arpa.slave";
masters {
192.5.5.241; // F.ROOT-SERVERS.NET.
};
@@ -345,14 +345,14 @@ zone "example.org" {
allow-update {
key "exampleorgkey";
};
- file "/etc/namedb/dynamic/example.org";
+ file "%%BIND_DESTETC%%/dynamic/example.org";
};
*/
/* Example of a slave reverse zone
zone "1.168.192.in-addr.arpa" {
type slave;
- file "/etc/namedb/slave/1.168.192.in-addr.arpa";
+ file "%%BIND_DESTETC%%/slave/1.168.192.in-addr.arpa";
masters {
192.168.1.1;
};
diff --git a/dns/bind99/files/patch-bin__dnssec__Makefile.in b/dns/bind99/files/patch-bin__dnssec__Makefile.in
deleted file mode 100644
index d0ac680f2f4c..000000000000
--- a/dns/bind99/files/patch-bin__dnssec__Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./bin/dnssec/Makefile.in.orig 2014-01-27 19:58:24.000000000 +0100
-+++ ./bin/dnssec/Makefile.in 2014-04-09 15:42:28.000000000 +0200
-@@ -55,12 +55,12 @@
-
- MANPAGES = dnssec-dsfromkey.8 dnssec-keyfromlabel.8 dnssec-keygen.8 \
- dnssec-revoke.8 dnssec-settime.8 dnssec-signzone.8 \
-- dnssec-verify.8
-+ dnssec-verify.8 dnssec-importkey.8
-
- HTMLPAGES = dnssec-dsfromkey.html dnssec-keyfromlabel.html \
- dnssec-keygen.html dnssec-revoke.html \
- dnssec-settime.html dnssec-signzone.html \
-- dnssec-verify.html
-+ dnssec-verify.html dnssec-importkey.html
-
- MANOBJS = ${MANPAGES} ${HTMLPAGES}
-
diff --git a/dns/bind99/files/patch-bin__python__Makefile.in b/dns/bind99/files/patch-bin__python__Makefile.in
deleted file mode 100644
index 34912063188a..000000000000
--- a/dns/bind99/files/patch-bin__python__Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./bin/python/Makefile.in.orig 2014-05-23 15:42:39.000000000 +0200
-+++ ./bin/python/Makefile.in 2014-06-24 14:12:26.000000000 +0200
-@@ -41,8 +41,8 @@
- $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${mandir}/man8
-
- install:: ${TARGETS} installdirs
-- ${INSTALL_PROGRAM} dnssec-checkds@EXEEXT@ ${DESTDIR}${sbindir}
-- ${INSTALL_PROGRAM} dnssec-coverage@EXEEXT@ ${DESTDIR}${sbindir}
-+ ${INSTALL_SCRIPT} dnssec-checkds@EXEEXT@ ${DESTDIR}${sbindir}
-+ ${INSTALL_SCRIPT} dnssec-coverage@EXEEXT@ ${DESTDIR}${sbindir}
- ${INSTALL_DATA} ${srcdir}/dnssec-checkds.8 ${DESTDIR}${mandir}/man8
- ${INSTALL_DATA} ${srcdir}/dnssec-coverage.8 ${DESTDIR}${mandir}/man8
-
diff --git a/dns/bind99/files/patch-configure b/dns/bind99/files/patch-configure
index 9c32b1500cef..f25f5d4de0e7 100644
--- a/dns/bind99/files/patch-configure
+++ b/dns/bind99/files/patch-configure
@@ -1,28 +1,11 @@
---- configure.orig 2014-03-27 06:00:33.000000000 +0900
-+++ configure 2014-03-27 06:02:11.000000000 +0900
-@@ -14160,6 +14160,8 @@
+--- configure.orig 2014-09-16 19:27:20 UTC
++++ configure
+@@ -14211,6 +14211,8 @@
"-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv" \
"-lgssapi" \
"-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lkrb5 -lgssapi_krb5 -lkrb5support -lk5crypto -lcom_err" \
+ "-lgssapi -lkrb5 -lgssapi_krb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
"-lgssapi -lkrb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
+ "-lgssapi -lkrb5 -lgssapi_krb5 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
"-lgssapi -lkrb5 -lhx509 -lcrypto -lcrypt -lasn1 -lroken -lcom_err" \
- "-lgss -lkrb5"
-@@ -14179,12 +14181,14 @@
- $as_echo_n "checking linking as $TRY_LIBS... " >&6; }
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-+#include <gssapi/gssapi.h>
-+#include <gssapi/gssapi_krb5.h>
-+#include <krb5.h>
-
- int
- main ()
- {
--gss_acquire_cred();krb5_init_context()
-- ;
-+gss_acquire_cred(0,0,0,0,0,0,0,0);krb5_init_context(0);gsskrb5_register_acceptor_identity(0);
- return 0;
- }
- _ACEOF
diff --git a/dns/bind99/pkg-plist b/dns/bind99/pkg-plist
index b1e83c7ec170..2b49573be7cd 100644
--- a/dns/bind99/pkg-plist
+++ b/dns/bind99/pkg-plist
@@ -7,8 +7,10 @@ bin/nsupdate
include/bind9/check.h
include/bind9/getaddresses.h
include/bind9/version.h
+include/dns/acache.h
include/dns/acl.h
include/dns/adb.h
+include/dns/bit.h
include/dns/byaddr.h
include/dns/cache.h
include/dns/callbacks.h
@@ -22,25 +24,34 @@ include/dns/dbtable.h
include/dns/diff.h
include/dns/dispatch.h
include/dns/dlz.h
+include/dns/dlz_dlopen.h
+include/dns/dns64.h
include/dns/dnssec.h
include/dns/ds.h
+include/dns/ecdb.h
include/dns/enumclass.h
include/dns/enumtype.h
include/dns/events.h
include/dns/fixedname.h
+include/dns/forward.h
include/dns/iptable.h
include/dns/journal.h
+include/dns/keydata.h
include/dns/keyflags.h
include/dns/keytable.h
include/dns/keyvalues.h
include/dns/lib.h
include/dns/log.h
+include/dns/lookup.h
include/dns/master.h
include/dns/masterdump.h
include/dns/message.h
include/dns/name.h
include/dns/ncache.h
include/dns/nsec.h
+include/dns/nsec3.h
+include/dns/opcode.h
+include/dns/order.h
include/dns/peer.h
include/dns/portlist.h
include/dns/private.h
@@ -59,19 +70,24 @@ include/dns/resolver.h
include/dns/result.h
include/dns/rootns.h
include/dns/rpz.h
+include/dns/rriterator.h
+include/dns/rrl.h
include/dns/sdb.h
include/dns/sdlz.h
include/dns/secalg.h
include/dns/secproto.h
include/dns/soa.h
include/dns/ssu.h
+include/dns/stats.h
include/dns/tcpmsg.h
include/dns/time.h
+include/dns/timer.h
include/dns/tkey.h
include/dns/tsec.h
include/dns/tsig.h
include/dns/ttl.h
include/dns/types.h
+include/dns/update.h
include/dns/validator.h
include/dns/version.h
include/dns/view.h
@@ -86,6 +102,8 @@ include/dst/result.h
include/isc/app.h
include/isc/assertions.h
include/isc/atomic.h
+include/isc/backtrace.h
+include/isc/base32.h
include/isc/base64.h
include/isc/bind9.h
include/isc/bitstring.h
@@ -111,6 +129,7 @@ include/isc/httpd.h
include/isc/int.h
include/isc/interfaceiter.h
include/isc/iterated_hash.h
+include/isc/keyboard.h
include/isc/lang.h
include/isc/lex.h
include/isc/lfsr.h
@@ -128,13 +147,17 @@ include/isc/namespace.h
include/isc/net.h
include/isc/netaddr.h
include/isc/netdb.h
+include/isc/netscope.h
include/isc/offset.h
include/isc/once.h
include/isc/ondestroy.h
include/isc/os.h
include/isc/parseint.h
include/isc/platform.h
+include/isc/pool.h
+include/isc/portset.h
include/isc/print.h
+include/isc/queue.h
include/isc/quota.h
include/isc/radix.h
include/isc/random.h
@@ -153,9 +176,11 @@ include/isc/sha2.h
include/isc/sockaddr.h
include/isc/socket.h
include/isc/stat.h
+include/isc/stats.h
include/isc/stdio.h
include/isc/stdlib.h
include/isc/stdtime.h
+include/isc/strerror.h
include/isc/string.h
include/isc/symtab.h
include/isc/syslog.h
@@ -184,6 +209,7 @@ include/isccc/util.h
include/isccc/version.h
include/isccfg/aclconf.h
include/isccfg/cfg.h
+include/isccfg/dnsconf.h
include/isccfg/grammar.h
include/isccfg/log.h
include/isccfg/namedconf.h
@@ -200,6 +226,8 @@ include/lwres/net.h
include/lwres/netdb.h
include/lwres/platform.h
include/lwres/result.h
+include/lwres/stdlib.h
+include/lwres/string.h
include/lwres/version.h
lib/libbind9.a
lib/libdns.a
@@ -352,23 +380,7 @@ sbin/rndc-confgen
%%NOBASE%%%%ETCDIR%%/master/localhost-forward.db
%%NOBASE%%%%ETCDIR%%/master/localhost-reverse.db
%%NOBASE%%%%ETCDIR%%/rndc.conf.sample
-%%NOBASE%%@exec mkdir -p %D/%%ETCDIR%%/dynamic
-%%NOBASE%%@exec chown bind:bind %D/%%ETCDIR%%/dynamic
-%%NOBASE%%@dirrmtry %%ETCDIR%%/dynamic
-%%NOBASE%%@exec mkdir -p %D/%%ETCDIR%%/master
-%%NOBASE%%@exec chown bind:bind %D/%%ETCDIR%%/master
-%%NOBASE%%@dirrmtry %%ETCDIR%%/master
-%%NOBASE%%@exec mkdir -p %D/%%ETCDIR%%/slave
-%%NOBASE%%@exec chown bind:bind %D/%%ETCDIR%%/slave
-%%NOBASE%%@dirrmtry %%ETCDIR%%/slave
-%%NOBASE%%@exec mkdir -p %D/%%ETCDIR%%/working
-%%NOBASE%%@exec chown bind:bind %D/%%ETCDIR%%/working
-%%NOBASE%%@dirrmtry %%ETCDIR%%/working
-%%NOBASE%%@dirrmtry %%ETCDIR%%
-@dirrm include/bind9
-@dirrm include/dns
-@dirrm include/dst
-@dirrmtry include/isc
-@dirrm include/isccc
-@dirrm include/isccfg
-@dirrm include/lwres
+%%NOBASE%%@dir(bind,bind,) %%ETCDIR%%/dynamic
+%%NOBASE%%@dir(bind,bind,) %%ETCDIR%%/master
+%%NOBASE%%@dir(bind,bind,) %%ETCDIR%%/slave
+%%NOBASE%%@dir(bind,bind,) %%ETCDIR%%/working