aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dns_mre/Makefile27
-rw-r--r--dns/dns_mre/distinfo2
-rw-r--r--dns/dns_mre/files/patch-dns_mre.c41
-rw-r--r--dns/dns_mre/files/patch-dns_mre.h10
-rw-r--r--dns/dns_mre/pkg-descr6
6 files changed, 0 insertions, 87 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 387845df7cde..2c0bda4dcc13 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -26,7 +26,6 @@
SUBDIR += dnrd
SUBDIR += dns2tcp
SUBDIR += dns_balance
- SUBDIR += dns_mre
SUBDIR += dnscap
SUBDIR += dnscheck
SUBDIR += dnscheckengine
diff --git a/dns/dns_mre/Makefile b/dns/dns_mre/Makefile
deleted file mode 100644
index 88510b0357fc..000000000000
--- a/dns/dns_mre/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# Created by: Tomoyuki Sakurai <cherry@trombik.org>
-# $FreeBSD$
-
-PORTNAME= dns_mre
-PORTVERSION= 1.0
-PORTREVISION= 1
-CATEGORIES= dns security
-MASTER_SITES= http://www.securebits.org/tools/
-DISTNAME= ${PORTNAME}-v${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= DNS Cache Poisoner/Overwriter
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-10
-
-NO_WRKSUBDIR= Yes
-
-PLIST_FILES= bin/dns_mre
-
-do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} -Wall main.c dns_mre.c -o dns_mre
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dns_mre ${STAGEDIR}${PREFIX}/bin/
-
-.include <bsd.port.mk>
diff --git a/dns/dns_mre/distinfo b/dns/dns_mre/distinfo
deleted file mode 100644
index de0d99e2436d..000000000000
--- a/dns/dns_mre/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (dns_mre-v1.0.tar.gz) = 7a3c264805686bedf06f10fa7536403d679cf69f269b95cb8a11d4f3e1d026e6
-SIZE (dns_mre-v1.0.tar.gz) = 21958
diff --git a/dns/dns_mre/files/patch-dns_mre.c b/dns/dns_mre/files/patch-dns_mre.c
deleted file mode 100644
index e2f87016e2eb..000000000000
--- a/dns/dns_mre/files/patch-dns_mre.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- dns_mre.c.orig 2008-08-02 01:23:19.000000000 +0900
-+++ dns_mre.c 2008-08-27 21:20:44.000000000 +0900
-@@ -160,7 +160,6 @@
- u_int8_t * udp_pointer = NULL;
- u_int8_t * dns_pointer = NULL;
- int dns_size;
-- int i;
-
- if( !answer_flag )
- printf("# Preparing query raw packet...");
-@@ -195,7 +194,7 @@
- u_int8_t * ip4_pointer = NULL;
- u_int8_t * udp_pointer = NULL;
- u_int8_t * dns_pointer = NULL;
-- int dns_size;
-+ int dns_size = 0;
- int i;
-
- if( !answer_flag )
-@@ -720,13 +719,6 @@
- exit(1);
- }
-
-- /* Connect to the DNS Server */
-- if( connect(sockfd, (struct sockaddr *) &q_d_addr, sizeof( q_d_addr )) == -1 )
-- {
-- perror("connect()");
-- exit(1);
-- }
--
- /* Send the DNS Query */
- if( (numbytes = sendto(sockfd, (char *) payload, payload_size, 0,
- (struct sockaddr *)&q_d_addr, sizeof( q_d_addr ))) == -1 )
-@@ -797,6 +789,7 @@
- " -x <no_txids> Number of static Transaction IDs to use (optional; default 15)\n"
- " -v Verbosity\n"
- , cmd);
-+ return 1;
- }
-
-
diff --git a/dns/dns_mre/files/patch-dns_mre.h b/dns/dns_mre/files/patch-dns_mre.h
deleted file mode 100644
index 0e7833febf49..000000000000
--- a/dns/dns_mre/files/patch-dns_mre.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- dns_mre.h.orig 2008-08-02 04:02:47.000000000 +0900
-+++ dns_mre.h 2008-08-02 04:02:51.000000000 +0900
-@@ -32,6 +32,7 @@
- #include <netdb.h>
- #include <arpa/inet.h>
- #include <string.h>
-+#include <time.h>
-
- /* Definitions */
- #define Q_S_PORT 2345 /* Query Source Port */
diff --git a/dns/dns_mre/pkg-descr b/dns/dns_mre/pkg-descr
deleted file mode 100644
index a4d605175fb6..000000000000
--- a/dns/dns_mre/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-DNS Multiple Race Exploiter is a tool that exploits an inherent flaw in the
-DNS Server Cache. By sending many queries to a DNS server along with fake
-replies, an attacker can successfuly writes a fake new entry in the DNS
-cache.
-
-WWW: http://www.securebits.org/dnsmre.html