aboutsummaryrefslogtreecommitdiffstats
path: root/editors/kile-kde4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/kile-kde4/Makefile')
-rw-r--r--editors/kile-kde4/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index 0327b843bc3b..b6c145bdfe3d 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -17,15 +17,23 @@ COMMENT= A LaTeX source editor for KDE
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
identify:${PORTSDIR}/graphics/ImageMagick
-CONFLICTS= kile-i18n-*
+CONFLICTS= kile-i18n-[0-9]*
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
+OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| syntax||g' ${WRKSRC}/src/kile/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_KPDF)
+RUN_DEPENDS+= kpdf:${PORTSDIR}/graphics/kdegraphics3
+.endif
+
+.include <bsd.port.post.mk>