aboutsummaryrefslogtreecommitdiffstats
path: root/editors/leafpad/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/leafpad/Makefile')
-rw-r--r--editors/leafpad/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/editors/leafpad/Makefile b/editors/leafpad/Makefile
index 9e533b0cf694..9b33a21f5a7e 100644
--- a/editors/leafpad/Makefile
+++ b/editors/leafpad/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= leafpad
-PORTVERSION= 0.8.9
-PORTREVISION= 6
+PORTVERSION= 0.8.16
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,12 +15,12 @@ MAINTAINER= radek@raadradd.com
COMMENT= GTK+ based simple text editor
USE_GNOME= gtk20 desktopfileutils intlhack
-USE_GETTEXT= YES
+USE_GETTEXT= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- PTHREAD_LIB="${PTHREAD_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-chooser
-
+INSTALLS_ICONS= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}