aboutsummaryrefslogtreecommitdiffstats
path: root/editors/mp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/mp/Makefile')
-rw-r--r--editors/mp/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
new file mode 100644
index 000000000000..27e5b252eba4
--- /dev/null
+++ b/editors/mp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mp
+# Date created: Apr 12, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp
+PORTVERSION= 3.0.98k
+CATEGORIES= editors
+MASTER_SITES= http://www.triptico.com/download/
+
+MAINTAINER= mark@kyne.com.au
+
+USE_GMAKE= yes
+MAKE_ARGS+= PREFIX="${PREFIX}"
+MAKEFILE= makefile
+
+pre-configure:
+ ${PERL} -pi -e "s@gcc -g -Wall@${CC} ${CFLAGS} -Wall@g" ${WRKSRC}/makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mp ${PREFIX}/bin
+
+.include <bsd.port.mk>