aboutsummaryrefslogtreecommitdiffstats
path: root/editors/textroom
diff options
context:
space:
mode:
Diffstat (limited to 'editors/textroom')
-rw-r--r--editors/textroom/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/editors/textroom/Makefile b/editors/textroom/Makefile
index 3116864d6876..612f1ec0fa2f 100644
--- a/editors/textroom/Makefile
+++ b/editors/textroom/Makefile
@@ -14,22 +14,16 @@ LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26 \
libcurl.so:${PORTSDIR}/ftp/curl
-USES= shared-mime-info
+USES= qmake shared-mime-info
USE_SDL= mixer
USE_QT4= moc_build qmake_build rcc_build uic_build corelib gui xml \
svg opengl qt3support
-QMAKE_ARGS= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE}
-HAS_CONFIGURE= yes
+QMAKE_ARGS= LOCALBASE=${LOCALBASE}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
${WRKSRC}/application/src/textroom.cpp \
${WRKSRC}/application/src/getaword.cpp \
${WRKSRC}/application/src/optionsdialog.cpp
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS} textroom.pro
-
.include <bsd.port.mk>