aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/mlview/Makefile2
-rw-r--r--editors/mlview/files/patch-configure.in15
-rw-r--r--editors/ooo-build/Makefile2
-rw-r--r--editors/xemacs-devel-mule/Makefile2
-rw-r--r--editors/xemacs-devel-mule/files/patch-configure.ac31
-rw-r--r--editors/xemacs-devel/Makefile2
-rw-r--r--editors/xemacs-devel/files/patch-configure.ac31
-rw-r--r--editors/yui/Makefile2
8 files changed, 42 insertions, 45 deletions
diff --git a/editors/mlview/Makefile b/editors/mlview/Makefile
index 28fe7b7c581f..3d0308291cb3 100644
--- a/editors/mlview/Makefile
+++ b/editors/mlview/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= barner@FreeBSD.org
COMMENT= A tree oriented XML editor for Gnome
USE_BZIP2= yes
-USE_AUTOTOOLS= autoconf:261 libtool:15
+USE_AUTOTOOLS= autoconf:262 libtool:15
USE_GNOME= eel2 gnomehack gnomeprefix gtksourceview
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/editors/mlview/files/patch-configure.in b/editors/mlview/files/patch-configure.in
index 9041b93283ce..46ba9f2cfc85 100644
--- a/editors/mlview/files/patch-configure.in
+++ b/editors/mlview/files/patch-configure.in
@@ -1,11 +1,14 @@
---- configure.in.orig Sat Jul 23 12:53:33 2005
-+++ configure.in Sat Jul 23 12:53:40 2005
-@@ -67,7 +67,7 @@
- \* 10000 + $MLVIEW_MINOR_VERSION \
- \* 100 + $MLVIEW_MICRO_VERSION`
+--- configure.in.orig 2005-07-03 17:17:49.000000000 +0000
++++ configure.in 2008-08-04 13:30:02.000000000 +0000
+@@ -69,6 +69,5 @@
-MLVIEW_EXE=$prefix/bin/mlv
+MLVIEW_EXE=$prefix/bin/mlview
AC_SUBST(MLVIEW_VERSION_NUMBER)
AC_SUBST(MLVIEW_VERSION)
- AC_SUBST(AC_PACKAGE_VERSION)
+-AC_SUBST(AC_PACKAGE_VERSION)
+ AC_SUBST(LIBMLVIEW_VERSION_NUMBER)
+@@ -76,3 +75,2 @@
+ AC_SUBST(LIBMLVIEW_VERSION)
+-AC_SUBST(AC_PACKAGE_VERSION)
+ AC_SUBST(MLVIEW_EXE)
diff --git a/editors/ooo-build/Makefile b/editors/ooo-build/Makefile
index dbed7f86f933..77a12e8b6163 100644
--- a/editors/ooo-build/Makefile
+++ b/editors/ooo-build/Makefile
@@ -45,7 +45,7 @@ OOO_LIBWPG= libwpg-0.1.0~cvs20070608.tar.gz
OOO_PATCHDIR=src680
MD5_FILE= ${.CURDIR}/distinfo
-USE_AUTOTOOLS= autoconf:261
+USE_AUTOTOOLS= autoconf:262
CONFIGURE_ARGS+= --enable-cairo
CONFIGURE_ARGS+= --with-system-xrender-headers
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index b6fd8735ffcc..c3e2e1faa81d 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -53,7 +53,7 @@ XEMACS_ARCH= ${MACHINE_ARCH}--freebsd
WRKSRC= ${WRKDIR}/xemacs-${XEMACS_VER:S/-b/./}
STRIP=
-USE_AUTOTOOLS= autoconf:261
+USE_AUTOTOOLS= autoconf:262
CONFIGURE_TARGET=--build=${XEMACS_ARCH}
CONFIGURE_ARGS+= --enable-mule \
diff --git a/editors/xemacs-devel-mule/files/patch-configure.ac b/editors/xemacs-devel-mule/files/patch-configure.ac
index d21c7f9b168b..c61834620e46 100644
--- a/editors/xemacs-devel-mule/files/patch-configure.ac
+++ b/editors/xemacs-devel-mule/files/patch-configure.ac
@@ -1,28 +1,25 @@
---- configure.ac.orig Thu Mar 30 21:11:17 2006
-+++ configure.ac Sat Apr 1 19:49:02 2006
-@@ -1272,6 +1272,7 @@
- dnl Straightforward OS determination
- case "$ac_cv_build" in
+--- configure.ac.orig 2007-05-21 03:50:13.000000000 +0000
++++ configure.ac 2008-08-04 13:51:25.000000000 +0000
+@@ -389,5 +389,7 @@
+ dnl
++dnl m4_fst disappeared without a trace in autoconf 2.62
++m4_define([xe_fst], [$1])dnl
+ define([XE_EXPAND_COMPLEX_OPTIONS],
+ [m4_if([$2], [], [],
+- [XE_EXPAND_COMPLEX_OPTION([$1], m4_fst($2))[]dnl
++ [XE_EXPAND_COMPLEX_OPTION([$1], xe_fst($2))[]dnl
+ XE_EXPAND_COMPLEX_OPTIONS([$1], XE_CDR($2))])])dnl
+@@ -1313,2 +1315,3 @@
*-*-linux* ) opsys=linux ;;
+ *-*-freebsd* ) opsys=freebsd ;;
*-*-netbsd* ) opsys=netbsd ;;
- *-*-openbsd* ) opsys=openbsd ;;
- *-*-nextstep* ) opsys=nextstep ;;
-@@ -3439,7 +3440,7 @@
- dnl #### How about /sw/include, and /opt/local/include?
- dnl these directories need to be the parent of the freetype directory
+@@ -3496,3 +3499,3 @@
for freetype_include_top in "/usr/X11R6/include/freetype2" \
- "/usr/include/freetype2"
+ "$with_site_includes/freetype2"
do
- if test -d $freetype_include_top; then
- AC_MSG_CHECKING([in ${freetype_include_top}/freetype2])
-@@ -5339,7 +5340,7 @@
- dnl Check for Berkeley DB.
- if test "$enable_database_berkdb" != "no"; then
+@@ -5420,3 +5423,3 @@
AC_MSG_CHECKING(for Berkeley db.h)
- for header in "db/db.h" "db.h"; do
+ for header in "/usr/include/db.h" "db/db.h" "db.h"; do
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #include <stdlib.h>
- #if !(defined __GLIBC__ && __GLIBC_MINOR__ >= 1)
diff --git a/editors/xemacs-devel/Makefile b/editors/xemacs-devel/Makefile
index f5b5e0d2d151..6c827593caa0 100644
--- a/editors/xemacs-devel/Makefile
+++ b/editors/xemacs-devel/Makefile
@@ -39,7 +39,7 @@ XEMACS_ARCH= ${CONFIGURE_TARGET}
WRKSRC= ${WRKDIR}/xemacs-${XEMACS_VER:S/-b/./}
STRIP=
-USE_AUTOTOOLS= autoconf:261
+USE_AUTOTOOLS= autoconf:262
CONFIGURE_TARGET=${MACHINE_ARCH}--freebsd
CONFIGURE_ARGS?=--enable-clash-detection \
diff --git a/editors/xemacs-devel/files/patch-configure.ac b/editors/xemacs-devel/files/patch-configure.ac
index d21c7f9b168b..5058b3f986d7 100644
--- a/editors/xemacs-devel/files/patch-configure.ac
+++ b/editors/xemacs-devel/files/patch-configure.ac
@@ -1,28 +1,25 @@
---- configure.ac.orig Thu Mar 30 21:11:17 2006
-+++ configure.ac Sat Apr 1 19:49:02 2006
-@@ -1272,6 +1272,7 @@
- dnl Straightforward OS determination
- case "$ac_cv_build" in
+--- configure.ac.orig 2007-05-21 03:50:13.000000000 +0000
++++ configure.ac 2008-08-04 13:50:15.000000000 +0000
+@@ -389,5 +389,7 @@
+ dnl
++dnl m4_fst disappeared without a trace in autoconf 2.62
++m4_define([xe_fst], [$1])dnl
+ define([XE_EXPAND_COMPLEX_OPTIONS],
+ [m4_if([$2], [], [],
+- [XE_EXPAND_COMPLEX_OPTION([$1], m4_fst($2))[]dnl
++ [XE_EXPAND_COMPLEX_OPTION([$1], xe_fst($2))[]dnl
+ XE_EXPAND_COMPLEX_OPTIONS([$1], XE_CDR($2))])])dnl
+@@ -1313,2 +1315,3 @@
*-*-linux* ) opsys=linux ;;
+ *-*-freebsd* ) opsys=freebsd ;;
*-*-netbsd* ) opsys=netbsd ;;
- *-*-openbsd* ) opsys=openbsd ;;
- *-*-nextstep* ) opsys=nextstep ;;
-@@ -3439,7 +3440,7 @@
- dnl #### How about /sw/include, and /opt/local/include?
- dnl these directories need to be the parent of the freetype directory
+@@ -3496,3 +3499,3 @@
for freetype_include_top in "/usr/X11R6/include/freetype2" \
- "/usr/include/freetype2"
+ "$with_site_includes/freetype2"
do
- if test -d $freetype_include_top; then
- AC_MSG_CHECKING([in ${freetype_include_top}/freetype2])
-@@ -5339,7 +5340,7 @@
- dnl Check for Berkeley DB.
- if test "$enable_database_berkdb" != "no"; then
+@@ -5420,3 +5423,3 @@
AC_MSG_CHECKING(for Berkeley db.h)
- for header in "db/db.h" "db.h"; do
+ for header in "/usr/include/db.h" "db/db.h" "db.h"; do
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #include <stdlib.h>
- #if !(defined __GLIBC__ && __GLIBC_MINOR__ >= 1)
diff --git a/editors/yui/Makefile b/editors/yui/Makefile
index 2d5616e37296..d4a3d1c64685 100644
--- a/editors/yui/Makefile
+++ b/editors/yui/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= citycat4@ngs.ru
COMMENT= Rich-featured multi-windows console text editor
USE_BZIP2= yes
-USE_AUTOTOOLS= autoconf:261
+USE_AUTOTOOLS= autoconf:262
MAN1= y.1