aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile9
-rw-r--r--editors/openoffice.org-3-devel/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index d912da05292a..d39b4faed5c9 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -152,6 +152,13 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--enable-wiki-publisher \
--enable-report-builder
+OOOEXTENSIONS+= minimizer/sun-presentation-minimizer.oxt
+OOOEXTENSIONS+= minimizer/sun-presentation-minimizer.oxt
+OOOEXTENSIONS+= presenter/presenter-screen.oxt
+OOOEXTENSIONS+= pdfimport/pdfimport.oxt
+OOOEXTENSIONS+= swext/wiki-publisher.oxt
+OOOEXTENSIONS+= sun-report-builder.oxt
+
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
@@ -242,6 +249,8 @@ do-install:
@${MKDIR} ${PREFIX}/${INSTALLATION_BASEDIR}
@cd ${WRKDIR}/tmp/opt/ ; ${TAR} cf - -C . . | ${TAR} xf - -C ${PREFIX}/${INSTALLATION_BASEDIR}
.endif
+ @${MKDIR} ${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
+ @cd ${WRKSRC}/solver/300/unxfbsdi.pro/bin/ ; ${INSTALL_DATA} ${OOOEXTENSIONS} ${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
post-install:
@${ECHO_MSG} "===> Add wrapper scripts";
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index d912da05292a..d39b4faed5c9 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -152,6 +152,13 @@ CONFIGURE_ARGS+= --with-gnu-cp=${LOCALBASE}/bin/gcp \
--enable-wiki-publisher \
--enable-report-builder
+OOOEXTENSIONS+= minimizer/sun-presentation-minimizer.oxt
+OOOEXTENSIONS+= minimizer/sun-presentation-minimizer.oxt
+OOOEXTENSIONS+= presenter/presenter-screen.oxt
+OOOEXTENSIONS+= pdfimport/pdfimport.oxt
+OOOEXTENSIONS+= swext/wiki-publisher.oxt
+OOOEXTENSIONS+= sun-report-builder.oxt
+
.if ${ARCH} == amd64
WITHOUT_MOZILLA= yes
LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost
@@ -242,6 +249,8 @@ do-install:
@${MKDIR} ${PREFIX}/${INSTALLATION_BASEDIR}
@cd ${WRKDIR}/tmp/opt/ ; ${TAR} cf - -C . . | ${TAR} xf - -C ${PREFIX}/${INSTALLATION_BASEDIR}
.endif
+ @${MKDIR} ${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
+ @cd ${WRKSRC}/solver/300/unxfbsdi.pro/bin/ ; ${INSTALL_DATA} ${OOOEXTENSIONS} ${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
post-install:
@${ECHO_MSG} "===> Add wrapper scripts";