aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile5
-rw-r--r--editors/libreoffice/files/patch-testtools__source__bridgetest__makefile.mk12
2 files changed, 15 insertions, 2 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index e1612f9bce44..b5235da7abf1 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -233,6 +233,9 @@ MAKE_ENV+= USE_GMAKE=1 DESTDIR=${LODESTDIR}
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/db${BDB_VER}
LDFLAGS+= -L${LOCALBASE}/lib
+# XXX Avoid -rpath pollution from bsd.openssl.mk.
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+
.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
WANT_PGSQL_VER= 90+
@@ -373,6 +376,8 @@ post-extract:
@${TOUCH} ${WRKSRC}/clone/repos_changed
post-patch:
+ @${FIND} ${WRKSRC} -type f -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -i '' -e 's#-Wl,-rpath,#-Wl,-z,origin -Wl,-rpath,#g'
@${REINPLACE_CMD} -e 's#5.1 5.0#${BDB_VER}#g' \
-e 's,-ldb$$dash$$dbver,-l${BDB_LIB_NAME},g' \
-e 's,"Linux" \&\& test "z$$enable_graphite","FreeBSD" \&\& test "z$$enable_graphite",g' \
diff --git a/editors/libreoffice/files/patch-testtools__source__bridgetest__makefile.mk b/editors/libreoffice/files/patch-testtools__source__bridgetest__makefile.mk
index c7bfec570e41..37261c0dd4e4 100644
--- a/editors/libreoffice/files/patch-testtools__source__bridgetest__makefile.mk
+++ b/editors/libreoffice/files/patch-testtools__source__bridgetest__makefile.mk
@@ -1,6 +1,14 @@
--- ./testtools/source/bridgetest/makefile.mk.orig 2012-08-08 09:00:06.000000000 -0400
-+++ ./testtools/source/bridgetest/makefile.mk 2012-08-22 16:18:28.000000000 -0400
-@@ -145,16 +145,6 @@
++++ ./testtools/source/bridgetest/makefile.mk 2012-08-27 15:06:28.000000000 -0400
+@@ -31,7 +31,6 @@
+ TARGET=bridgetest
+ USE_DEFFILE=TRUE
+ ENABLE_EXCEPTIONS=TRUE
+-VISIBILITY_HIDDEN=TRUE
+ LIBTARGET=NO
+
+ .INCLUDE: settings.mk
+@@ -145,16 +144,6 @@
runtest : $(DLLDEST)$/uno_types.rdb $(DLLDEST)$/uno_services.rdb makefile.mk \
$(SHL1TARGETN) $(SHL2TARGETN) $(SHL3TARGETN)