aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile2
-rw-r--r--editors/vim/files/vimrc1
2 files changed, 2 insertions, 1 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index fb2cba242c40..1f288bf5f32b 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vim
PORTVERSION= 7.4.${PATCHLEVEL}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= editors
MASTER_SITES= VIM:source \
${MASTER_SITE_VIM:S|unix|patches/${PORTVERSION:R}|}:patch \
diff --git a/editors/vim/files/vimrc b/editors/vim/files/vimrc
index 21df2d3f1b11..cd041eb34648 100644
--- a/editors/vim/files/vimrc
+++ b/editors/vim/files/vimrc
@@ -2,6 +2,7 @@ if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
set fileencodings=ucs-bom,utf-8,latin1
endif
+let g:is_posix = 1
set nocompatible
set bs=indent,eol,start
set history=50