aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/abiword-extras/Makefile27
-rw-r--r--editors/abiword-extras/distinfo3
-rw-r--r--editors/abiword-extras/pkg-descr10
-rw-r--r--editors/abiword-extras/pkg-plist41
5 files changed, 82 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index e55ac4199a0c..902018f6593a 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -6,6 +6,7 @@
SUBDIR += 2bsd-vi
SUBDIR += MathPlanner
SUBDIR += abiword
+ SUBDIR += abiword-extras
SUBDIR += abiword-plugins
SUBDIR += aee
SUBDIR += aewan
diff --git a/editors/abiword-extras/Makefile b/editors/abiword-extras/Makefile
new file mode 100644
index 000000000000..4b5bd7b20a04
--- /dev/null
+++ b/editors/abiword-extras/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: abiword-extras
+# Date created: 2008-04-16
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= abiword-extras
+PORTVERSION= 2.6.2
+CATEGORIES= editors
+MASTER_SITES= http://www.abisource.com/downloads/%SUBDIR%/${PORTVERSION}/source/
+MASTER_SITE_SUBDIR= abiword
+DIST_SUBDIR= AbiWord
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= AbiWord extras (Templates, clipart, dictionary files, etc)
+
+BUILD_DEPENDS= abiword:${PORTSDIR}/editors/abiword
+RUN_DEPENDS= abiword:${PORTSDIR}/editors/abiword
+
+GNU_CONFIGURE= yes
+
+post-install:
+##### Makes abiword CRASH
+ @${RM} -f ${PREFIX}/share/abiword-2.6/templates/Fax-Coversheet.awt
+
+.include <bsd.port.mk>
diff --git a/editors/abiword-extras/distinfo b/editors/abiword-extras/distinfo
new file mode 100644
index 000000000000..c24d22f17080
--- /dev/null
+++ b/editors/abiword-extras/distinfo
@@ -0,0 +1,3 @@
+MD5 (AbiWord/abiword-extras-2.6.2.tar.gz) = 0cca01e0943e598e274350a77cde2ede
+SHA256 (AbiWord/abiword-extras-2.6.2.tar.gz) = 19ea0ada915d116c1d6bd962df3679215cbc71ad22664b90ebe173bb49ad2dc4
+SIZE (AbiWord/abiword-extras-2.6.2.tar.gz) = 2070478
diff --git a/editors/abiword-extras/pkg-descr b/editors/abiword-extras/pkg-descr
new file mode 100644
index 000000000000..b783d4b115f8
--- /dev/null
+++ b/editors/abiword-extras/pkg-descr
@@ -0,0 +1,10 @@
+AbiWord extras (Templates, clipart, dictionary files, etc)
+
+This directory tree contains GPL or GPL-compatible files used by AbiSuite
+that are very big and/or that don't change very often. The files in this
+directory may or may not be used in the actual compilation, but probably
+are used in the installation or at runtime. These files were kept out of
+the abi/user directory to decrease download times for those pulling down
+periodic tarballs.
+
+WWW: http://www.abisource.com/
diff --git a/editors/abiword-extras/pkg-plist b/editors/abiword-extras/pkg-plist
new file mode 100644
index 000000000000..ce22934c4bf5
--- /dev/null
+++ b/editors/abiword-extras/pkg-plist
@@ -0,0 +1,41 @@
+share/abiword-2.6/clipart/book.png
+share/abiword-2.6/clipart/chip.png
+share/abiword-2.6/clipart/fun.png
+share/abiword-2.6/clipart/gear.png
+share/abiword-2.6/clipart/gnomea.png
+share/abiword-2.6/clipart/gnomeb.png
+share/abiword-2.6/clipart/gnomec.png
+share/abiword-2.6/clipart/gnomecorner.png
+share/abiword-2.6/clipart/gnomed.png
+share/abiword-2.6/clipart/gnomedecor1.png
+share/abiword-2.6/clipart/gnomedecor2.png
+share/abiword-2.6/clipart/gnomee.png
+share/abiword-2.6/clipart/gnomeflowers.png
+share/abiword-2.6/clipart/gnomeline.png
+share/abiword-2.6/clipart/idea.png
+share/abiword-2.6/clipart/lamp.png
+share/abiword-2.6/clipart/monitor.png
+share/abiword-2.6/clipart/music1.png
+share/abiword-2.6/clipart/pinceau.png
+share/abiword-2.6/clipart/simca.png
+share/abiword-2.6/clipart/surprise.png
+share/abiword-2.6/clipart/together.png
+share/abiword-2.6/clipart/toolbox.png
+share/abiword-2.6/clipart/tree.png
+share/abiword-2.6/clipart/tux_bordelais.png
+share/abiword-2.6/clipart/weather.png
+share/abiword-2.6/clipart/write.png
+share/abiword-2.6/dictionary/ca-ES-barbarism.xml
+share/abiword-2.6/dictionary/en-AU-barbarism.xml
+share/abiword-2.6/dictionary/es-MX-barbarism.xml
+share/abiword-2.6/dictionary/ispell_dictionary_list.xml
+share/abiword-2.6/templates/A4.awt
+share/abiword-2.6/templates/Business-Letter.awt
+share/abiword-2.6/templates/Business-Report.awt
+share/abiword-2.6/templates/Employee-Directory.awt
+share/abiword-2.6/templates/Friendly-Letter.awt
+share/abiword-2.6/templates/Memo.awt
+share/abiword-2.6/templates/Press-Release.awt
+share/abiword-2.6/templates/Resume.awt
+share/abiword-2.6/templates/Two-Columns.awt
+share/abiword-2.6/templates/US-Letter.awt