aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/vim5/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index e97762d8ced0..f80528cb4118 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -47,8 +47,14 @@ MLINKS+= vim.1 gvim.1 vim.1 gview.1 vim.1 rgvim.1 vim.1 rgview.1
.include <bsd.port.pre.mk>
+# Determine if we need xpg4.
+# No xpg4 in libc below 400020 and 500005
+.if ${OSVERSION} < 400020 && ${OSVERSION} < 500005
+LIBS=-lxpg4
+.endif
+
.if !defined(LITE)
-MAKE_ARGS+= X_LIBS=-lxpg4 CONF_OPT_MAX="--enable-max-features"
+MAKE_ARGS+= CONF_OPT_MAX="--enable-max-features"
I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
.if defined(WITH_ATHENA)
@@ -67,7 +73,7 @@ MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp --enable-pythoninterp --enable-tc
.endif
.else # LITE
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x"
+MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable-tclinterp"
.endif # LITE
/span>3-9/+29 * - add MASTER_SITE_LOCALdinoex2011-08-071-1/+2 * - Get Rid MD5 supportmiwi2011-03-201-1/+0 * - fix crash on png filesdinoex2010-09-273-26/+56 * - honor CCdinoex2010-04-101-1/+1 * - update to 1.4.1dinoex2010-03-281-2/+2 * - update to jpeg-8dinoex2010-02-051-2/+2