aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/linux-geepee32/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux-geepee32/Makefile')
-rw-r--r--emulators/linux-geepee32/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/emulators/linux-geepee32/Makefile b/emulators/linux-geepee32/Makefile
new file mode 100644
index 000000000000..80553ddc0ac3
--- /dev/null
+++ b/emulators/linux-geepee32/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: geepee32
+# Date Created: 05 October 2003
+# Whom: <arundel@gmx.net>
+#
+# $FreeBSD$
+
+PORTNAME= geepee32
+PORTVERSION= 30
+CATEGORIES= emulators linux
+MASTER_SITES= http://users.skynet.be/firefly/gp32/project/geepee32/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}_linux_sdl_${PORTVERSION}
+
+MAINTAINER= arundel@gmx.net
+COMMENT= The only GP32 emulator for x86 archs
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+TARGET_DIR= ${PREFIX}/geepee32
+
+STRIP=
+PROG_FILES= ${WRKDIR}/geepee32
+DATA_FILES= ${FILESDIR}/geepee32.sh
+
+do-build:
+
+do-install:
+ ${INSTALL} -d -m 777 ${TARGET_DIR} && \
+ ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR} && \
+ ${INSTALL_SCRIPT} ${DATA_FILES} ${TARGET_DIR}
+
+post-install:
+ ${TOUCH} ${TARGET_DIR}/iic.bin && \
+ ${LN} -s ${TARGET_DIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Please don't mail us with requests for ROM dump."
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>