aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/mame/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/mame/Makefile')
-rw-r--r--emulators/mame/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 599dafc0adf6..24f2cd7889ea 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmame
-PORTVERSION= 0.120u2
+PORTVERSION= 0.122u8
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.alepulver.com.ar/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -17,6 +17,7 @@ COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
USE_ZIP= yes
USE_GL= yes
USE_GMAKE= yes
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
USE_SDL= sdl
MAKEFILE= makefile
@@ -25,8 +26,8 @@ SUB_FILES= ${PORTNAME} pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/sdlmame
-.for f in obj/sdl/mame/build/file2str obj/sdl/mame/build/png2bdc mame testkeys romcmp \
- chdman jedutil makemeta regrep srcclean
+.for f in obj/sdl/mame/build/file2str obj/sdl/mame/build/png2bdc mame \
+ testkeys romcmp chdman jedutil makemeta regrep srcclean
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/sdlmame
.endfor
${MKDIR} ${DATADIR}
@@ -52,8 +53,4 @@ post-install:
USE_GCC= 4.2+
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile
-.endif
-
.include <bsd.port.post.mk>