aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/pkg-message55
2 files changed, 26 insertions, 31 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 997e45950c8d..ae199026a881 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.11.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://bellard.org/qemu/
diff --git a/emulators/qemu/pkg-message b/emulators/qemu/pkg-message
index 64cdd9b427c2..78dc04d5635e 100644
--- a/emulators/qemu/pkg-message
+++ b/emulators/qemu/pkg-message
@@ -21,29 +21,32 @@ FreeBSD host notes
kernel'...) Enabling /dev/rtc doesn't seem to help either (not included
since it needs a patch to emulators/rtc.)
-- update: the above problem has gotten worse with FreeBSD guests somewhere
- before 8.0, mainly since the kernel now usually wants double or even
- quadruple number of timer irqs compared to HZ if it detects an apic (and at
- least early versions of FreeBSD 8 had a bug that essentially halved qemu's
- clock rate too); the only reason you usually don't see symptoms of this with
- FreeBSD 8 guests is they automatically reduce their HZ to 100 when running
+- Update: the above problem has gotten worse with FreeBSD guests
+ somewhere before 8.0, mainly since the kernel now usually wants
+ double or even quadruple number of timer irqs compared to HZ if
+ it detects an apic (and at least early versions of FreeBSD 8 had
+ a bug that essentially halved qemu's clock rate too); the only
+ reason you usually don't see symptoms of this with FreeBSD 8
+ guests is they automatically reduce their HZ to 100 when running
in a VM while the default for the host kernel is still HZ=1000.
- workarounds: for i386 guests you can disable the apic in the guest by
- setting
+ Workaround: you can disable the apic clock in the guest by setting
- hint.apic.0.disabled=1
+ hint.apic.0.clock="0"
- in loader.conf(5) (or manually at the loader prompt), otherwise the only thing
- you can do is either reduce the guest's HZ to, say, 100 by setting e.g.
+ in loader.conf(5) (or manually at the loader prompt), if that
+ doesn't work the only things you can do is either reduce the
+ guest's HZ to, say, 100 by setting e.g.
kern.hz="100"
- from the loader as above (which usually is a good idea in a VM anyway and
- FreeBSD 8 now does by itself as mentioned), or if that's not possible
- increase the host's HZ to 2000 or even 4000 from the loader in the same way.
+ from the loader as above (which usually is a good idea in a VM
+ anyway and FreeBSD 8 now does by itself as mentioned), or otherwise
+ increase the host's HZ to 2000 or even 4000 from the loader in
+ the same way.
-- The -smb option (smb-export local dir to guest) needs the net/samba3
- port/package installed in addition to qemu.
+- The -smb option (smb-export local dir to guest using the default
+ slirp networking) needs the net/samba34 port/package installed
+ in addition to qemu.
- If you want to use usb devices connected to the host in the guest
(usb_add host:... monitor command; this doesn't work on FreeBSD 8 and
@@ -83,17 +86,12 @@ FreeBSD host notes
guests or other weird cdrom problems then thats probably because the guest
has atapicam loaded, which for reasons still to be determined has problems
with qemu's now by default enabled cdrom dma. You can build the port with
- CDROM_DMA disabled to disable it.
+ CDROM_DMA disabled to disable it. [Looks like this is fixed in recent
+ FreeBSD guest versions.]
- If you build qemu wihout SDL and then get crashes running it try passing it
-nographic. This should probably be default in that case...
-- Perhaps it should be noted that if you want to use qemu with -m 512 or
- larger on 6.x/i386 hosts you need to increase the kern.maxdsiz tunable in
- loader.conf(5) since the default is 512 MB, and qemu needs memory for itself
- also. (7.0 and up now use jemalloc which uses mmap(2) and isn't affected by
- kern.maxdsiz anymore.)
-
- If you use kqemu make sure your kqemu.ko is always in sync with your kernel
(like with any kld installed outside of base), i.e. rebuild its port
whenever you update the kernel - especially if you are switching branches or
@@ -111,10 +109,10 @@ FreeBSD host notes
cp /boot/pxeboot pxeboot-qemu && chmod +w pxeboot-qemu && echo >>pxeboot-qemu
- and then use pxeboot-qemu. Actually you need latest -stable or -current btx
- code (from after 7.0 was released) because of the real mode boot problem, so
- use at least pxeboot from there. And I just did that for the pxeboot
- extracted out of
+ and then use pxeboot-qemu. Actually you need recent btx code
+ (from after 7.0 was released) because of the real mode boot
+ problem, so use at least pxeboot from there. And I just did that
+ for the pxeboot extracted out of
ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/200805/7.0-STABLE-200805-i386-bootonly.iso
@@ -133,9 +131,6 @@ FreeBSD host notes
however that kqemu now can also be used with the 32 bit qemu even on amd64
hosts as of the 20080620 update.)
-- The new (optional) pcap code cannot talk to the host on 6.x because the
- necessary bpf feature (BIOCFEEDBACK) hasn't (yet?) been merged there.
-
- kqemu passes the host tsc to the guest as-is so depending on your cpu and
guest you _may_ need to tell the guest to avoid relying on the tsc (notsc
kernel parameter with linux), or if that doesn't work force qemu onto a