aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/sdlmame/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/sdlmame/Makefile')
-rw-r--r--emulators/sdlmame/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/emulators/sdlmame/Makefile b/emulators/sdlmame/Makefile
new file mode 100644
index 000000000000..025557cdac03
--- /dev/null
+++ b/emulators/sdlmame/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: sdlmame
+# Date created: 2007-01-10
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdlmame
+PORTVERSION= 0.112u2
+CATEGORIES= emulators
+MASTER_SITES= http://rbelmont.mameworld.info/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= SDL port of the popular MAME (Multi Arcade Machine Emulator)
+
+USE_ZIP= yes
+USE_GL= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+MAKEFILE= makefile
+
+SUB_FILES= ${PORTNAME} pkg-message
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+.for f in mame file2str romcmp chdman jedutil
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${PORTNAME}
+.endfor
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ui.bdf ${DATADIR}
+ cd ${DATADIR} && ${MKDIR} artwork cfg comments diff ini nvram roms
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs ${DOCSDIR}
+.endif
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>