aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine-devel
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/wine-devel')
-rw-r--r--emulators/wine-devel/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 5ee2d55631dc..be9bb3d98df2 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -60,6 +60,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" Off \
+ DOSBOX "Use DOSBox to run MS-DOS programs" Off \
GNUTLS "Use GnuTLS" Off \
HAL "Use HAL (Hardware Abstraction Layer)" Off \
LDAP "Use LDAP" Off \
@@ -78,6 +79,10 @@ CONFIGURE_ARGS+= --with-cups
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
.endif
+.ifdef WITH_DOSBOX
+RUN_DEPENDS+= dosbox:${PORTSDIR}/emulators/dosbox
+.endif
+
.ifdef WITH_GNUTLS
CONFIGURE_ARGS+= --with-gnutls
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls