aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/xbraitenberg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/xbraitenberg/Makefile')
-rw-r--r--emulators/xbraitenberg/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/emulators/xbraitenberg/Makefile b/emulators/xbraitenberg/Makefile
new file mode 100644
index 000000000000..00d4cd806124
--- /dev/null
+++ b/emulators/xbraitenberg/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: xbraitenberg
+# Date created: 28 Mar 2004
+# Whom: krion
+#
+# $FreeBSD$
+#
+
+PORTNAME= xbraitenberg
+PORTVERSION= 0.8
+CATEGORIES= emulators
+MASTER_SITES= http://www.lcdf.org/~eddietwo/xbraitenberg/
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= A Braitenberg vehicle simulator with pseudo-physics
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib"
+
+PLIST_FILES= bin/xbraitenberg
+
+.include <bsd.port.mk>