aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gxmame/Makefile10
-rw-r--r--emulators/tiemu3/Makefile4
2 files changed, 9 insertions, 5 deletions
diff --git a/emulators/gxmame/Makefile b/emulators/gxmame/Makefile
index 88a147a69e62..33643773b53f 100644
--- a/emulators/gxmame/Makefile
+++ b/emulators/gxmame/Makefile
@@ -15,7 +15,7 @@ COMMENT= GXmame is a GTK frontend for xmame
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= xmame:${PORTSDIR}/emulators/xmame
-USES= pathfix
+USES= pathfix
USE_GNOME= gtk20 intlhack gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -23,11 +23,13 @@ GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-xmame-dir=${LOCALBASE}/share/xmame
-.if defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-PLIST_SUB+= NLS=""
.endif
MAN6= gxmame.6
diff --git a/emulators/tiemu3/Makefile b/emulators/tiemu3/Makefile
index 2439f729d47a..27962c66a989 100644
--- a/emulators/tiemu3/Makefile
+++ b/emulators/tiemu3/Makefile
@@ -27,7 +27,9 @@ CONFIGURE_ARGS= --disable-gdb
MAN1= tiemu.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB= NLS=""
.else