aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index af377ef144e3..7e7d00531fff 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -21,6 +21,9 @@ EXTRACT_ONLY= VirtualBox-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= vbox@FreeBSD.org
COMMENT= A general-purpose full virtualizer for x86 hardware
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
as86:${PORTSDIR}/devel/dev86 \
xsltproc:${PORTSDIR}/textproc/libxslt \
@@ -30,9 +33,6 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
curl.6:${PORTSDIR}/ftp/curl
RUN_DEPENDS= /boot/modules/vboxdrv.ko:${PORTSDIR}/emulators/virtualbox-ose-kmod-legacy
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}_OSE
ONLY_FOR_ARCHS= i386 amd64
USE_CDRTOOLS= yes
@@ -80,6 +80,8 @@ PLIST_SUB+= PYTHON_VER=${PYTHON_VER} \
SUB_LIST+= VBOXUSER=${VBOXUSER}
USE_RC_SUBR+= vboxheadless
+.include <bsd.port.pre.mk>
+
KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE} VBOX_FREEBSD_SRC=${SRC_BASE}/sys
KMK_FLAGS=
@@ -174,8 +176,6 @@ KMK_ARCH= freebsd.${ARCH}
PLIST_SUB+= I386="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} > 900012
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-include-iprt-string.h
.endif