aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-utils/Makefile2
-rw-r--r--emulators/qemu-utils/files/patch-Makefile14
2 files changed, 15 insertions, 1 deletions
diff --git a/emulators/qemu-utils/Makefile b/emulators/qemu-utils/Makefile
index 57ba7ff60393..a0e14ef14d35 100644
--- a/emulators/qemu-utils/Makefile
+++ b/emulators/qemu-utils/Makefile
@@ -19,7 +19,7 @@ OPTIONS_EXCLUDE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
MASTERDIR= ${.CURDIR}/../qemu
PLIST= ${.CURDIR}/pkg-plist
DESCR= ${.CURDIR}/pkg-descr
-EXTRA_PATCHES= ${.CURDIR}/files/patch-configure
+EXTRA_PATCHES= ${.CURDIR}/files/patch-Makefile ${.CURDIR}/files/patch-configure
PKGMESSAGE=
PORTDOCS= qemu-doc.html qmp-commands.txt
diff --git a/emulators/qemu-utils/files/patch-Makefile b/emulators/qemu-utils/files/patch-Makefile
new file mode 100644
index 000000000000..2d9d97f96926
--- /dev/null
+++ b/emulators/qemu-utils/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig 2017-03-31 14:07:03 UTC
++++ Makefile
+@@ -484,11 +490,6 @@ endif
+ ifeq ($(CONFIG_GTK),y)
+ $(MAKE) -C po $@
+ endif
+- $(INSTALL_DIR) "$(DESTDIR)$(qemu_datadir)/keymaps"
+- set -e; for x in $(KEYMAPS); do \
+- $(INSTALL_DATA) $(SRC_PATH)/pc-bios/keymaps/$$x "$(DESTDIR)$(qemu_datadir)/keymaps"; \
+- done
+- $(INSTALL_DATA) $(BUILD_DIR)/trace-events-all "$(DESTDIR)$(qemu_datadir)/trace-events-all"
+ for d in $(TARGET_DIRS); do \
+ $(MAKE) $(SUBDIR_MAKEFLAGS) TARGET_DIR=$$d/ -C $$d $@ || exit 1 ; \
+ done