aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/xmame/Makefile273
-rw-r--r--emulators/xmame/distinfo2
-rw-r--r--emulators/xmame/files/patch-src-unix-osinline.h11
-rw-r--r--emulators/xmame/files/patch-src-unix-video-drivers-xf86_dga1.c13
-rw-r--r--emulators/xmame/files/patch-src-unix-video-drivers-xf86_dga2.c13
-rw-r--r--emulators/xmame/files/pkg-message.in8
-rw-r--r--emulators/xmame/pkg-descr20
-rw-r--r--emulators/xmame/pkg-plist61
9 files changed, 0 insertions, 402 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index a317033e4f14..9adcd3e3bcea 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -179,7 +179,6 @@
SUBDIR += xbraitenberg
SUBDIR += xcpc
SUBDIR += xhomer
- SUBDIR += xmame
SUBDIR += xsystem35
SUBDIR += xzx
SUBDIR += yabause
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
deleted file mode 100644
index 4d0a740dccc6..000000000000
--- a/emulators/xmame/Makefile
+++ /dev/null
@@ -1,273 +0,0 @@
-# Created by: Donald Burr <dburr@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME?= xmame
-PORTVERSION?= 0.106
-PORTREVISION?= 5
-CATEGORIES= emulators
-MASTER_SITES= http://www.franksworld.org/dist/xmame/ \
- http://x.mame.net/download/ \
- http://www.energyhq.es.eu.org/files/ \
- http://www.energyhq.be/files/ \
- http://www.pkix.net/mirror/x.mame.net/
-DISTNAME= xmame-${XMAMEVERSION}
-
-MAINTAINER?= ports@FreeBSD.org
-COMMENT?= UNIX/X11 port of the Multi Arcade Machine Emulator (MAME)
-
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-07
-
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
-
-NO_CDROM= License does not permit selling
-
-USES= perl5 gmake
-USE_BZIP2= yes
-MAKE_ARGS+= CC="${CC}" ARCH=freebsd
-WANT_SDL= yes
-WANT_GNOME= yes
-MAKE_JOBS_UNSAFE= yes
-
-# Are we building MAME or MESS? (also set by slave ports)
-MAMEMESS?= mame
-
-SUB_FILES= pkg-message
-MAN6= x${MAMEMESS}.6
-
-OPTIONS_DEFINE= ASM68K DOCS ESOUND NETWORK OPENGL OPTIMIZATION SDL SVGALIB X11
-OPTIONS_DEFAULT= SDL
-
-SVGALIB_DESC= Enable Svgalib support
-ASM68K_DESC= Enable the speedier but buggy 68k emulator
-OPTIMIZATION_DESC= Enable maximum C compiler optimization
-NETWORK_DESC= Include support for network play (**BROKEN**)
-
-XMAMEVERSION?= ${PORTVERSION}
-
-DATADIR= ${PREFIX}/share/x${MAMEMESS}
-DOCSDIR= ${PREFIX}/share/doc/x${MAMEMESS}
-PLIST_SUB+= MAMEMESS="x${MAMEMESS}" SPOOLGAMES="${SPOOLGAMES}"
-.if ${MAMEMESS} == "mame"
-PLIST_SUB+= MAMEONLY="" MESSONLY="@comment "
-.else
-.if ${MAMEMESS} == "mess"
-PLIST_SUB+= MAMEONLY="@comment " MESSONLY=""
-.else
-IGNORE= cannot install: MAMEMESS must be set to one of "mame" or "mess".
-.endif
-.endif
-
-# Where do we want game spool data?
-SPOOLGAMES?= /var/games
-
-# Docs list
-GENERALDOCS= changes.unix \
- dga2.txt \
- img/xmame.jpg \
- liesmich.unix \
- multiplayer-readme.txt \
- xmame-doc-2.html \
- xmame-doc-3.html \
- xmame-doc-4.html \
- xmame-doc-5.html \
- xmame-doc-6.html \
- xmame-doc-7.html \
- xmame-doc.html \
- xmame-doc.lyx \
- xmame-doc.txt \
- xmame-gdoc-1.html \
- xmame-gdoc-2.html \
- xmame-gdoc-3.html \
- xmame-gdoc-4.html \
- xmame-gdoc-5.html \
- xmame-gdoc-6.html \
- xmame-gdoc-7.html \
- xmame-gdoc-8.html \
- xmame-gdoc.html \
- xmame.css
-XMAMEDOCS=
-XMESSDOCS= mess/credits.htm \
- mess/faq.htm \
- mess/imgtool.txt \
- mess/messnew.txt \
- mess/messroms.txt \
- mess/sysinfo.dat \
-
-GLDOCS= changes.opengl
-.if ${MAMEMESS} == "mame"
-ALLDOCS= ${GENERALDOCS} ${XMAMEDOCS}
-.else
-ALLDOCS= ${GENERALDOCS} ${XMESSDOCS}
-.endif
-
-#
-# Various options are processed here.
-#
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
-.if ${PORT_OPTIONS:MASM68K}
-ASM_COMMENT=
-.else
-ASM_COMMENT=\#
-.endif
-
-# Option WITH_OPTIMIZATION
-.if ${PORT_OPTIONS:MOPTIMIZATION}
-CFLAGS+= -O3 -Wall -Wno-unused -funroll-loops \
- -fstrength-reduce -fomit-frame-pointer -ffast-math \
- -falign-functions=4 -falign-jumps=4 -falign-loops=4
-.endif
-
-SDLSOUNDCOMMENT= \#
-
-# Option DISPLAY_TARGET
-.if ${PORT_OPTIONS:MSDL}
-USE_SDL= sdl
-DISPLAY_TARGET= sdl
-DISPLAY_METHOD= SDL
-SDLSOUNDCOMMENT=
-.endif
-
-.if ${PORT_OPTIONS:MOPENGL}
-USE_XORG+= x11
-DISPLAY_TARGET= opengl
-CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-USE_GL= yes
-DISPLAY_METHOD= x11
-PLIST_SUB+= OPENGL=""
-ALL_DOCS+= ${GLDOCS}
-.else
-PLIST_SUB+= OPENGL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSVGALIB}
-DISPLAY_TARGET= svgalib
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
-USE_XORG+= xpm
-DISPLAY_METHOD= svgalib
-.endif
-
-.if ${PORT_OPTIONS:MX11}
-DISPLAY_METHOD= x11
-USE_XORG+= x11
-.endif
-
-# Option WITH_ESOUND
-.if ${PORT_OPTIONS:MESOUND}
-ESOUNDCOMMENT=
-USE_GNOME= esound
-.else
-ESOUNDCOMMENT=\#
-.endif
-
-# XXX Network support is *broken* in 0.85+, leave commented out for now
-# Option WITH_NETWORK
-.if ${PORT_OPTIONS:MNETWORK}
-BROKEN= Networking support is currently broken
-NETWORK=
-.else
-NETWORK=\#
-.endif
-
-# The large number of sed regexes here is intended to make this port a whole
-# lot easier to maintain - please don't convert them into a patch.
-do-configure:
- ${REINPLACE_CMD} -e "s@= gcc@?= ${CC}@g" \
- -e "s@^TARGET.*@TARGET = ${MAMEMESS}@g" \
- -e "s@# XMAME_NET@${NETWORK}XMAME_NET@g" \
- -e "s@# X86_ASM_68000 =@${ASM_COMMENT}X86_ASM_68000 =@g" \
- -e "s@^CFLAGS.*@CFLAGS ?= ${CFLAGS}@g" \
- -e "s@^INSTALL_GROUP.*@INSTALL_GROUP = wheel@g" \
- -e "s@# LIBS.*@LIBS = -L${LOCALBASE}/lib@g" \
- -e "s@# INCLUDES.*@INCLUDES = -I${LOCALBASE}/include@g" \
- -e "s@^PREFIX.*@PREFIX = ${PREFIX}@g" \
- -e "s@/share/man@/man@g" \
- -e "s@^MY_CPU.*@MY_CPU = ${ARCH}@g" \
- -e "s@^ARCH.*@ARCH = freebsd@g" \
- -e "s@# SOUND_ESOUND@${ESOUNDCOMMENT}SOUND_ESOUND@g" \
- -e "s@# SOUND_SDL@${SDLSOUNDCOMMENT}SOUND_SDL@g" \
- -e "s@^DISPLAY_METHOD.*@DISPLAY_METHOD = ${DISPLAY_METHOD}@g" \
- -e "s@# X11_DGA@X11_DGA@g" \
- -e "s@/usr/X11R6@${LOCALBASE}@g" \
- -e "s@^SDL_CONFIG.*@SDL_CONFIG = ${SDL_CONFIG}@g" \
- -e "s@^GLLIBS += .*@GLLIBS += ${PTHREAD_LIBS}@g" \
- ${WRKSRC}/makefile.unix
-.if ${OSVERSION} < 800064
- ${REINPLACE_CMD} -e "s@# JOY_USB@JOY_USB@g" ${WRKSRC}/makefile.unix
-.endif
-
-.if ${PORT_OPTIONS:MSDL}
- ${REINPLACE_CMD} -e "s@# JOY_SDL = 1@JOY_SDL = 1@g" ${WRKSRC}/makefile.unix
-.endif
-
-.if ${PORT_OPTIONS:MOPENGL}
- ${REINPLACE_CMD} -e "s@# X11_OPENGL = 1@X11_OPENGL = 1@g" ${WRKSRC}/makefile.unix
-.endif
-
-# png.h conflicts with libpng.
-.for f in mess/artworkx.c mess/artworkx.h src/artwork.c \
- src/romload.c src/video.c src/png.c src/unix/video-drivers/glexport.c
-
- ${REINPLACE_CMD} -e "s@\"png.h\"@\"mame_png.h\"@g" ${WRKSRC}/${f}
-
-.endfor
- ${LN} -s ${WRKSRC}/src/png.h ${WRKSRC}/src/mame_png.h
-
-post-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} SDL_VIDEODRIVER=aalib \
- ${GMAKE} doc/x${MAMEMESS}.6
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} SDL_VIDEODRIVER=aalib \
- ${GMAKE} doc/x${MAMEMESS}rc.dist
- @${CP} ${WRKSRC}/doc/x${MAMEMESS}rc.dist \
- ${WRKSRC}/doc/x${MAMEMESS}rc.dist.sed
- ${SED} -e "s@^spooldir.*\$$@spooldir ${SPOOLGAMES}/x${MAMEMESS}@" \
- -e "s@^rompath.*\$$@rompath ${DATADIR}/roms@" \
- ${WRKSRC}/doc/x${MAMEMESS}rc.dist.sed > ${WRKSRC}/doc/x${MAMEMESS}rc.dist
-
-post-install:
-.if ${MAMEMESS} == "mame"
- ${INSTALL_PROGRAM} ${WRKSRC}/xml2info ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/romcmp ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/bin
-.endif
-
-.if ${MAMEMESS} == "mess"
- ${INSTALL_PROGRAM} ${WRKSRC}/imgtool ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/dat2html ${PREFIX}/bin
-.endif
-
- ${MV} ${PREFIX}/bin/x${MAMEMESS}.${DISPLAY_METHOD} \
- ${PREFIX}/bin/x${MAMEMESS}
- ${CHOWN} root:games ${PREFIX}/bin/x${MAMEMESS}
- ${CHMOD} u-s,g+s ${PREFIX}/bin/x${MAMEMESS}
- ${MKDIR} ${DATADIR}/roms
- ${MKDIR} ${SPOOLGAMES}/x${MAMEMESS}
- ${CHOWN} -R root:games ${SPOOLGAMES}/x${MAMEMESS}
- ${CHMOD} 775 ${SPOOLGAMES}/x${MAMEMESS}
- ${INSTALL_DATA} ${WRKSRC}/doc/x${MAMEMESS}rc.dist \
- ${PREFIX}/etc/x${MAMEMESS}rc.sample
- ${LN} -sf ${PREFIX}/etc/x${MAMEMESS}rc \
- ${DATADIR}/x${MAMEMESS}rc
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/img
-.for f in ${ALLDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
-.endfor
-.endif
-.if ${MAMEMESS} == "mess"
- ${INSTALL_DATA} ${WRKSRC}/doc/mess/sysinfo.dat \
- ${DATADIR}/history.dat
-.endif
-.if ${MAMEMESS} == "mame"
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/emulators/xmame/distinfo b/emulators/xmame/distinfo
deleted file mode 100644
index 112a4cc7dfb5..000000000000
--- a/emulators/xmame/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (xmame-0.106.tar.bz2) = a385d86adebc2eb53b560bb522cf569569a74c4104605a8e7d61f1caa0f5e4df
-SIZE (xmame-0.106.tar.bz2) = 17117298
diff --git a/emulators/xmame/files/patch-src-unix-osinline.h b/emulators/xmame/files/patch-src-unix-osinline.h
deleted file mode 100644
index 09410545a2f0..000000000000
--- a/emulators/xmame/files/patch-src-unix-osinline.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/unix/osinline.h.orig 2006-05-15 18:47:35.000000000 +0200
-+++ src/unix/osinline.h 2013-08-28 11:04:54.000000000 +0200
-@@ -32,7 +32,7 @@ INLINE int _vec_mult(int x, int y)
- : "=&a" (result) /* the result has to go in eax */
- : "mr" (x), /* x and y can be regs or mem */
- "mr" (y)
-- : "%edx", "%cc" /* clobbers edx and flags */
-+ : "%edx", "cc" /* clobbers edx and flags */
- );
- return result;
- }
diff --git a/emulators/xmame/files/patch-src-unix-video-drivers-xf86_dga1.c b/emulators/xmame/files/patch-src-unix-video-drivers-xf86_dga1.c
deleted file mode 100644
index b29f978c1329..000000000000
--- a/emulators/xmame/files/patch-src-unix-video-drivers-xf86_dga1.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- src/unix/video-drivers/xf86_dga1.c.orig Sun Mar 20 22:10:35 2005
-+++ src/unix/video-drivers/xf86_dga1.c Sun Mar 20 22:12:24 2005
-@@ -7,6 +7,7 @@
- #include <string.h>
- #include <sys/types.h>
- #include <sys/wait.h>
-+#include <sys/time.h>
- #include <sys/resource.h>
- #include <X11/Xlib.h>
- #include <X11/Xutil.h>
-
diff --git a/emulators/xmame/files/patch-src-unix-video-drivers-xf86_dga2.c b/emulators/xmame/files/patch-src-unix-video-drivers-xf86_dga2.c
deleted file mode 100644
index cd372d28a131..000000000000
--- a/emulators/xmame/files/patch-src-unix-video-drivers-xf86_dga2.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- src/unix/video-drivers/xf86_dga2.c.orig Sun Mar 20 22:16:38 2005
-+++ src/unix/video-drivers/xf86_dga2.c Sun Mar 20 22:16:53 2005
-@@ -10,6 +10,7 @@
- #include <string.h>
- #include <sys/types.h>
- #include <sys/wait.h>
-+#include <sys/time.h>
- #include <sys/resource.h>
- #include <X11/Xlib.h>
- #include <X11/Xutil.h>
-
diff --git a/emulators/xmame/files/pkg-message.in b/emulators/xmame/files/pkg-message.in
deleted file mode 100644
index 2bbbda6cee1f..000000000000
--- a/emulators/xmame/files/pkg-message.in
+++ /dev/null
@@ -1,8 +0,0 @@
-###############################################################################
-
-The xmame emulator was installed.
-
-To install additional MAME files (like cheats, hiscore, history, artwork,
-etc.) please use the "emulators/mame-extras" port.
-
-###############################################################################
diff --git a/emulators/xmame/pkg-descr b/emulators/xmame/pkg-descr
deleted file mode 100644
index 27be58bf7d70..000000000000
--- a/emulators/xmame/pkg-descr
+++ /dev/null
@@ -1,20 +0,0 @@
-XMAME is an arcade game machine emulator for UNIX/X11. It will emulate
-the hardware, video, sound, and other services, of many classic arcade
-game machines.
-
-As of this release, XMAME supports an incredible 2843 arcade games, and
-the number grows every day! A partial list of the (more popular and
-well-known) games currently supported by this emulator include:
-
-PacMan, Ms. PacMan, Jr. PacMan, Super PacMan, Dig Dug, Star Trek, Galaga,
-Space Invaders, Tempest, Frogger, Mr. Do!, Battle Zone, Missile Command,
-Gyruss, Kangaroo, Moon Patrol, Phoenix, Q*Bert, Rally X, Robotron,
-Star Wars, Zaxxon, Bubble Bobble, Snow Bros, ... you get the idea.
-
-To run these games, however, you will need images of the ROM chips that
-are used on these games. If you actually have one of these games (or the
-motherboard to one of them), and access to a ROM burner, it is a fairly
-trivial process to make ROM image files for use with XMAME. If you DON'T
-have access to a ROM burner, or you don't own one of these video games
-(and you are aware of the possible legal ramifications of doing this),
-you can obtain ROM images for XMAME on the Net.
diff --git a/emulators/xmame/pkg-plist b/emulators/xmame/pkg-plist
deleted file mode 100644
index 615136ca2476..000000000000
--- a/emulators/xmame/pkg-plist
+++ /dev/null
@@ -1,61 +0,0 @@
-bin/%%MAMEMESS%%
-%%MAMEONLY%%bin/xml2info
-bin/chdman
-%%MAMEONLY%%bin/romcmp
-%%MESSONLY%%bin/imgtool
-%%MESSONLY%%bin/dat2html
-%%MAMEONLY%%bin/jedutil
-etc/%%MAMEMESS%%rc.sample
-%%DATADIR%%/%%MAMEMESS%%rc
-%%PORTDOCS%%%%DOCSDIR%%/changes.unix
-%%PORTDOCS%%%%DOCSDIR%%/dga2.txt
-%%PORTDOCS%%%%DOCSDIR%%/xmame.jpg
-%%PORTDOCS%%%%DOCSDIR%%/liesmich.unix
-%%PORTDOCS%%%%DOCSDIR%%/multiplayer-readme.txt
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc-2.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc-3.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc-4.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc-5.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc-6.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc-7.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc.lyx
-%%PORTDOCS%%%%DOCSDIR%%/xmame-doc.txt
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc-1.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc-2.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc-3.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc-4.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc-5.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc-6.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc-7.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc-8.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame-gdoc.html
-%%PORTDOCS%%%%DOCSDIR%%/xmame.css
-%%MESSONLY%%%%PORTDOCS%%%%DOCSDIR%%/credits.htm
-%%MESSONLY%%%%PORTDOCS%%%%DOCSDIR%%/faq.htm
-%%MESSONLY%%%%PORTDOCS%%%%DOCSDIR%%/imgtool.txt
-%%MESSONLY%%%%PORTDOCS%%%%DOCSDIR%%/messnew.txt
-%%MESSONLY%%%%PORTDOCS%%%%DOCSDIR%%/messroms.txt
-%%MESSONLY%%%%PORTDOCS%%%%DOCSDIR%%/sysinfo.dat
-%%MESSONLY%%%%DATADIR%%/history.dat
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/img
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%OPENGL%%%%DATADIR%%/cab/glmame/cabfront.jpg
-%%OPENGL%%%%DATADIR%%/cab/glmame/cabtitle.jpg
-%%OPENGL%%%%DATADIR%%/cab/glmame/glmame.cab
-%%OPENGL%%@dirrm %%DATADIR%%/cab/glmame
-%%OPENGL%%%%DATADIR%%/cab/glmamejau/cabfront.jpg
-%%OPENGL%%%%DATADIR%%/cab/glmamejau/cabside.jpg
-%%OPENGL%%%%DATADIR%%/cab/glmamejau/cabtitle.jpg
-%%OPENGL%%%%DATADIR%%/cab/glmamejau/glmamejau.cab
-%%OPENGL%%@dirrm %%DATADIR%%/cab/glmamejau
-%%OPENGL%%%%DATADIR%%/cab/trans/trans.cab
-%%OPENGL%%@dirrm %%DATADIR%%/cab/trans
-%%OPENGL%%@dirrm %%DATADIR%%/cab
-@exec mkdir -p %D/%%DATADIR%%/roms || true
-@dirrm %%DATADIR%%/roms
-@dirrm %%DATADIR%%
-@exec mkdir -p %%SPOOLGAMES%%/%%MAMEMESS%% || true
-@exec chown root:games %%SPOOLGAMES%%/%%MAMEMESS%% || true
-@exec chmod 775 %%SPOOLGAMES%%/%%MAMEMESS%% || true
-@dirrmtry %%SPOOLGAMES%%/%%MAMEMESS%%