aboutsummaryrefslogtreecommitdiffstats
path: root/finance/homebank/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/homebank/Makefile')
-rw-r--r--finance/homebank/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/finance/homebank/Makefile b/finance/homebank/Makefile
new file mode 100644
index 000000000000..5f299d77f7a1
--- /dev/null
+++ b/finance/homebank/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: homebank
+# Date created: 24 June 2006
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= homebank
+DISTVERSION= 3.2alpha1
+CATEGORIES= finance
+MASTER_SITES= http://homebank.free.fr/public/
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= Manage your personal accounts at home
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_GNOME= gtk20
+USE_GETTEXT= yes
+USE_DOS2UNIX= src/*
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+DOCS= AUTHORS COPYING ChangeLog LICENSE NEWS README
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>