aboutsummaryrefslogtreecommitdiffstats
path: root/finance/p5-Business-OnlinePayment-SurePay/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/p5-Business-OnlinePayment-SurePay/Makefile')
-rw-r--r--finance/p5-Business-OnlinePayment-SurePay/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/finance/p5-Business-OnlinePayment-SurePay/Makefile b/finance/p5-Business-OnlinePayment-SurePay/Makefile
index 8486e6ec0d73..47861c4f39ef 100644
--- a/finance/p5-Business-OnlinePayment-SurePay/Makefile
+++ b/finance/p5-Business-OnlinePayment-SurePay/Makefile
@@ -23,4 +23,10 @@ PERL_CONFIGURE= yes
MAN3= Business::OnlinePayment::SurePay.3
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ -e '$$_="" if /use 5/;' \
+ -e '$$_="" if /use warnings/;' \
+ ${WRKSRC}/SurePay.pm
+
.include <bsd.port.mk>