aboutsummaryrefslogtreecommitdiffstats
path: root/finance/xtrader/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/xtrader/Makefile')
-rw-r--r--finance/xtrader/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/finance/xtrader/Makefile b/finance/xtrader/Makefile
new file mode 100644
index 000000000000..3c8cb4b0fdaf
--- /dev/null
+++ b/finance/xtrader/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xtrader
+# Date created: 2005-04-16
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xtrader
+PORTVERSION= 0.99.9
+CATEGORIES= finance
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Technical analysis program for financial instruments
+
+LIB_DEPENDS= ptypes.20:${PORTSDIR}/devel/ptypes \
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKEFILE= Makefile.linux
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+NO_WRKSUBDIR= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/xtrader \
+ %%DATADIR%%/sample.xt
+PLIST_DIRS= %%DATADIR%%
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/sample.xt ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/xtrader ${PREFIX}/bin
+
+.include <bsd.port.mk>