aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
Diffstat (limited to 'finance')
-rw-r--r--finance/qhacc/Makefile3
-rw-r--r--finance/quantlib/Makefile7
2 files changed, 6 insertions, 4 deletions
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index dada24044e6e..478ace8c2b63 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_QT_VER= 2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
@@ -25,7 +26,7 @@ post-extract:
pre-patch:
.for file in configure src/Makefile.in
- @${PERL} -pi -e 's|/moc|/${MOC:T}|g ; \
+ @${REINPLACE_CMD} -e 's|/moc|/${MOC:T}|g ; \
s|-lqt|-l${QTNAME}|g ; \
s|-O2 -Wall|\@CXXFLAGS\@|g' ${WRKSRC}/${file}
.endfor
diff --git a/finance/quantlib/Makefile b/finance/quantlib/Makefile
index 7a41106859de..83853fda4edf 100644
--- a/finance/quantlib/Makefile
+++ b/finance/quantlib/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/QuantLib-${PORTVERSION}
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_LIBTOOL= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
@@ -26,10 +27,10 @@ MAN1= DiscreteHedging.1 EuropeanOption.1 SwapValuation.1 \
quantlib-config.1
pre-patch:
- @${PERL} -pi -e 's|-g -O3|\$$CXXFLAGS|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-g -O3|\$$CXXFLAGS|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | \
- ${XARGS} ${PERL} -pi -e 's|-g -O.|\@CXXFLAGS\@|g'
+ ${XARGS} ${REINPLACE_CMD} -e 's|-g -O.|\@CXXFLAGS\@|g'
@${FIND} ${WRKSRC}/Examples -name "Makefile.in" | \
- ${XARGS} ${PERL} -pi -e 's|-pedantic -Wall|-O0|g'
+ ${XARGS} ${REINPLACE_CMD} -e 's|-pedantic -Wall|-O0|g'
.include <bsd.port.mk>