aboutsummaryrefslogtreecommitdiffstats
path: root/french/aster/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'french/aster/Makefile')
-rw-r--r--french/aster/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/french/aster/Makefile b/french/aster/Makefile
index 5caac5a3a3c8..6ee8c5cf40d4 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -48,6 +48,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Gnuplot:${PORTSDIR}/math/py-gnuplot \
EXTRACT_CMD= ${TAR}
EXTRACT_BEFORE_ARGS= -xf
EXTRACT_AFTER_ARGS= # empty
+USE_GCC= 3.2
USE_PYTHON= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
@@ -60,10 +61,6 @@ PKGMESSAGE= ${PKGDIR}/pkg-message.sans-astk
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-#BROKEN= Does not build on systems prior 5.x - work in progress...
-.endif
-
.if defined(WITH_BLAS)
LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas
.else
@@ -106,7 +103,11 @@ PLIST_SUB+= HOMARD="@comment " HOMARDDIR=""
RUN_DEPENDS+= ${PYNUMERIC}
.endif
+.if ${OSVERSION} < 500039
+F77= g77-${USE_GCC:C/\.//}
+.else
F77?= f77
+.endif
FFLAGS?= -O2
TK_VER?= 8.3