aboutsummaryrefslogtreecommitdiffstats
path: root/french/aster/files
diff options
context:
space:
mode:
Diffstat (limited to 'french/aster/files')
-rw-r--r--french/aster/files/patch-as_setup.py24
-rw-r--r--french/aster/files/patch-products.py14
2 files changed, 13 insertions, 25 deletions
diff --git a/french/aster/files/patch-as_setup.py b/french/aster/files/patch-as_setup.py
index 13d83fc41f0c..2aa326d64935 100644
--- a/french/aster/files/patch-as_setup.py
+++ b/french/aster/files/patch-as_setup.py
@@ -1,15 +1,15 @@
---- as_setup.py.orig 2010-02-09 10:04:57.000000000 +0100
-+++ as_setup.py 2010-02-20 15:49:39.000000000 +0100
-@@ -47,6 +47,8 @@
+--- as_setup.py.orig 2010-07-07 18:18:13.000000000 +0200
++++ as_setup.py 2010-08-12 19:01:09.000000000 +0200
+@@ -46,6 +46,8 @@
+ import compileall
import imp
- import shutil
import pprint
+import fileinput
+import string
+ import distutils.sysconfig as SC
from types import StringTypes
EnumTypes=(list, tuple)
-
-@@ -449,6 +451,17 @@
+@@ -472,6 +474,17 @@
if iextr_as:
self.Clean(to_delete=path)
@@ -27,15 +27,3 @@
#-------------------------------------------------------------------------------
def Configure(self, **kargs):
"""Configuration of the product.
-@@ -1302,7 +1315,10 @@
- from socket import gethostname, gethostbyaddr
- if host==None:
- host = gethostname()
-- fqn, alias, ip = gethostbyaddr(host)
-+ try:
-+ fqn, alias, ip = gethostbyaddr(host)
-+ except:
-+ fqn='put-your-host-name.here'
- if fqn.find('localhost')>-1:
- alias=[a for a in alias if a.find('localhost')<0]
- if len(alias)>0:
diff --git a/french/aster/files/patch-products.py b/french/aster/files/patch-products.py
index e113812f25ad..f5519abafd7c 100644
--- a/french/aster/files/patch-products.py
+++ b/french/aster/files/patch-products.py
@@ -1,9 +1,9 @@
---- products.py.orig 2010-02-09 10:04:58.000000000 +0100
-+++ products.py 2010-02-17 21:35:50.000000000 +0100
-@@ -900,16 +900,19 @@
+--- products.py.orig 2010-07-07 18:18:13.000000000 +0200
++++ products.py 2010-08-12 19:08:43.000000000 +0200
+@@ -907,16 +907,19 @@
'HOME_PYTHON', 'PYTHON_EXE', 'PYTHONLIB',
'HOME_MUMPS', 'HOME_ZMAT', 'HOME_MPI', 'INCLUDE_MUMPS', 'HOME_METIS',
- 'HOME_MED', 'HOME_HDF', 'HOME_CRPCRS', 'HOME_NUMERIC',
+ 'HOME_MED', 'HOME_HDF', 'HOME_CRPCRS', 'HOME_NUMPY', 'USE_NUMPY',
- 'LD', 'CC', 'F77', 'F90', 'CXXLIB', 'OTHERLIB',],
+ 'LD', 'CC', 'F77', 'F90', 'LDFLAGS', 'SYSLIB',
+ 'CFLAGS', 'CFLAGS_DBG',
@@ -24,7 +24,7 @@
'NOBUILD', ],
)
cfg['ENV_SH'] = cfg.get('ENV_SH', '')
-@@ -945,6 +948,19 @@
+@@ -959,6 +962,19 @@
opt['FFLAGS'] = '-O2'
zmat_platform='Linux'
mpilibs.extend(['mpich'])
@@ -44,7 +44,7 @@
elif cfg['IFDEF'] == 'LINUX64':
opt['SYSLIB'] = '-Wl,--allow-multiple-definition -Wl,--export-dynamic -lieee -ldl -lutil -lm'
opt['LDFLAGS'] = '-v'
-@@ -1017,11 +1033,12 @@
+@@ -1031,11 +1047,12 @@
cfg['MEDLIB']=''
# ----- libs c++ (for MED and ZMAT)
@@ -62,7 +62,7 @@
# ----- MUMPS
if cfg['HOME_MUMPS'] != '':
-@@ -1030,12 +1047,15 @@
+@@ -1044,12 +1061,15 @@
if not less_than_version(dict_prod['mumps'], '4.8.0'):
mumps_lib.extend(['smumps', 'cmumps', 'mumps_common'])
mumps_lib.extend(['pord', 'mpiseq'])