aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 46ef4acdf402..2ca954c957be 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -202,6 +202,13 @@ post-install:
# Setting LC_ALL=C is a kludge; maybe curl/libcurl shouldn't actually use
# the user's locale when dates are sent to the server.
test: build
+.if defined(WITHOUT_PROXY)
+ @${ECHO_MSG} "******************************************"
+ @${ECHO_MSG} "* You have disabled curl proxy support. *"
+ @${ECHO_MSG} "* Some tests SHALL FAIL! *"
+ @${ECHO_MSG} "* This is being addressed. *"
+ @${ECHO_MSG} "******************************************"
+.endif
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} LC_ALL=C ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.include <bsd.port.post.mk>