aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/curlpp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/curlpp')
-rw-r--r--ftp/curlpp/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 1ce2e7b63afb..2aa2fdbdcf09 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -26,6 +26,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --disable-ewarning
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
+BROKEN= "Does not compile on alpha 4.x"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
@@ -33,4 +39,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/test/example*.cpp ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>