aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/gftp/files
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/gftp/files')
-rw-r--r--ftp/gftp/files/patch-ab16
-rw-r--r--ftp/gftp/files/patch-lib-fsplib_fsplib.c47
-rw-r--r--ftp/gftp/files/patch-lib-fsplib_fsplib.h24
-rw-r--r--ftp/gftp/files/patch-lib-protocols.c18
-rw-r--r--ftp/gftp/files/patch-lib::pty.c11
-rw-r--r--ftp/gftp/files/patch-src::gtk::options_dialog.c11
-rw-r--r--ftp/gftp/files/patch-src::text::gftp-text.c18
7 files changed, 25 insertions, 120 deletions
diff --git a/ftp/gftp/files/patch-ab b/ftp/gftp/files/patch-ab
index df7f5c923f37..cd71fd8709dd 100644
--- a/ftp/gftp/files/patch-ab
+++ b/ftp/gftp/files/patch-ab
@@ -1,8 +1,8 @@
---- docs/Makefile.in.orig Wed Nov 10 20:13:26 2004
-+++ docs/Makefile.in Wed Nov 10 20:15:59 2004
-@@ -167,16 +167,20 @@
+--- docs/Makefile.in.orig 2008-12-04 19:27:08.000000000 +0100
++++ docs/Makefile.in 2008-12-04 19:30:20.000000000 +0100
+@@ -247,14 +247,18 @@
+ sysconfdir = @sysconfdir@
target_alias = @target_alias@
-
man_MANS = gftp.1
+.ifndef WITHOUT_X11
SUBDIRS = sample.gftp
@@ -10,14 +10,12 @@
EXTRA_DIST = USERS-GUIDE gftp.1 gftp.desktop gftp.lsm gftp.png parse-netrc.pl \
gftp-faq.sgml
-
+.ifdef HAVE_GNOME
Utilitiesdir = $(datadir)/applications
Utilities_DATA = gftp.desktop
-
Iconsdir = $(datadir)/pixmaps
Icons_DATA = gftp.png
+.endif
- subdir = docs
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ all: all-recursive
+
+ .SUFFIXES:
diff --git a/ftp/gftp/files/patch-lib-fsplib_fsplib.c b/ftp/gftp/files/patch-lib-fsplib_fsplib.c
deleted file mode 100644
index 151b3bfb8c2d..000000000000
--- a/ftp/gftp/files/patch-lib-fsplib_fsplib.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- lib/fsplib/fsplib.c.orig 2005-01-19 03:03:45.000000000 +0100
-+++ lib/fsplib/fsplib.c 2007-11-05 16:37:32.000000000 +0100
-@@ -612,7 +612,7 @@
- entry->d_reclen = fentry.reclen;
- strncpy(entry->d_name,fentry.name,MAXNAMLEN);
-
-- if (fentry.namlen > MAXNAMLEN)
-+ if (fentry.namlen >= MAXNAMLEN)
- {
- entry->d_name[MAXNAMLEN + 1 ] = '\0';
- #ifdef HAVE_NAMLEN
-@@ -680,9 +680,19 @@
- /* skip file date and file size */
- dir->dirpos += 9;
- /* read file name */
-- entry->name[255 + 1] = '\0';
-+ entry->name[255] = '\0';
- strncpy(entry->name,(char *)( dir->data + dir->dirpos ),MAXNAMLEN);
-+ /* check for ASCIIZ encoded filename */
-+ if (memchr(dir->data + dir->dirpos,0,dir->datasize - dir->dirpos) != NULL)
-+ {
- namelen = strlen( (char *) dir->data+dir->dirpos);
-+ }
-+ else
-+ {
-+ /* \0 terminator not found at end of filename */
-+ *result = NULL;
-+ return 0;
-+ }
- /* skip over file name */
- dir->dirpos += namelen +1;
-
-@@ -709,12 +719,12 @@
-
- struct dirent * fsp_readdir(FSP_DIR *dirp)
- {
-- static struct dirent entry;
-+ static dirent_workaround entry;
- struct dirent *result;
-
-
- if (dirp == NULL) return NULL;
-- if ( fsp_readdir_r(dirp,&entry,&result) )
-+ if ( fsp_readdir_r(dirp,&entry.dirent,&result) )
- return NULL;
- else
- return result;
diff --git a/ftp/gftp/files/patch-lib-fsplib_fsplib.h b/ftp/gftp/files/patch-lib-fsplib_fsplib.h
deleted file mode 100644
index 5d2d7449b053..000000000000
--- a/ftp/gftp/files/patch-lib-fsplib_fsplib.h
+++ /dev/null
@@ -1,24 +0,0 @@
---- lib/fsplib/fsplib.h.orig 2005-01-19 03:04:02.000000000 +0100
-+++ lib/fsplib/fsplib.h 2007-11-05 16:37:32.000000000 +0100
-@@ -1,6 +1,8 @@
- #ifndef _FSPLIB_H
- #define _FSPLIB_H 1
- #include <time.h>
-+#include <stddef.h>
-+
- /* The FSP v2 protocol support library - public interface */
-
- /*
-@@ -138,6 +140,12 @@
- unsigned int pos; /* position of next packet */
- } FSP_FILE;
-
-+
-+typedef union dirent_workaround {
-+ struct dirent dirent;
-+ char fill[offsetof (struct dirent, d_name) + MAXNAMLEN + 1];
-+} dirent_workaround;
-+
- /* function prototypes */
-
- /* session management */
diff --git a/ftp/gftp/files/patch-lib-protocols.c b/ftp/gftp/files/patch-lib-protocols.c
new file mode 100644
index 000000000000..e24aab9708d8
--- /dev/null
+++ b/ftp/gftp/files/patch-lib-protocols.c
@@ -0,0 +1,18 @@
+--- lib/protocols.c.orig 2008-12-04 21:35:37.000000000 +0100
++++ lib/protocols.c 2008-12-04 21:36:25.000000000 +0100
+@@ -457,6 +457,7 @@
+ fle->file = tmpfile;
+ }
+
++#if GLIB_MAJOR_VERSION > 1
+ if (ret >= 0 && fle->file != NULL)
+ {
+ if (g_utf8_validate (fle->file, -1, NULL))
+@@ -472,6 +473,7 @@
+ }
+ }
+ }
++#endif
+
+ if (ret >= 0 && !request->cached && request->cachefd > 0 &&
+ request->last_dir_entry != NULL)
diff --git a/ftp/gftp/files/patch-lib::pty.c b/ftp/gftp/files/patch-lib::pty.c
index f7c16d130878..21423eea8079 100644
--- a/ftp/gftp/files/patch-lib::pty.c
+++ b/ftp/gftp/files/patch-lib::pty.c
@@ -50,17 +50,6 @@
#elif HAVE_GRANTPT
#include <stropts.h>
-@@ -78,8 +121,8 @@
-
- if ((fdm = open ("/dev/ptmx", O_RDWR)) < 0)
- return (GFTP_ERETRYABLE);
--
-- if (grantpt (fdm) < 0)
-+
-+ if (grantpt (fdm) < 0)
- {
- close (fdm);
- return (GFTP_ERETRYABLE);
@@ -123,49 +166,6 @@
#endif
diff --git a/ftp/gftp/files/patch-src::gtk::options_dialog.c b/ftp/gftp/files/patch-src::gtk::options_dialog.c
deleted file mode 100644
index 2fb1b0bd6a24..000000000000
--- a/ftp/gftp/files/patch-src::gtk::options_dialog.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gtk/options_dialog.c.orig Sat Feb 5 16:42:53 2005
-+++ src/gtk/options_dialog.c Sat Feb 5 16:45:15 2005
-@@ -1002,7 +1002,7 @@
- gtk_widget_show (box);
-
- #if GTK_MAJOR_VERSION == 1
-- tempwid = gtk_label_new (_("Type:"))
-+ tempwid = gtk_label_new (_("Type:"));
- #else
- tempwid = gtk_label_new_with_mnemonic (_("_Type:"));
- #endif
diff --git a/ftp/gftp/files/patch-src::text::gftp-text.c b/ftp/gftp/files/patch-src::text::gftp-text.c
deleted file mode 100644
index 0e1bf3bd9fa7..000000000000
--- a/ftp/gftp/files/patch-src::text::gftp-text.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/text/gftp-text.c.orig Sat Feb 5 16:38:03 2005
-+++ src/text/gftp-text.c Sat Feb 5 16:39:26 2005
-@@ -185,6 +185,7 @@
- else
- infd = stdin;
-
-+#if GLIB_MAJOR_VERSION > 1
- locale_question = g_locale_from_utf8 (question, -1, NULL, NULL, NULL);
- if (locale_question != NULL)
- {
-@@ -193,6 +194,7 @@
- g_free (locale_question);
- }
- else
-+#endif
- printf ("%s%s%s ", GFTPUI_COMMON_COLOR_BLUE, question,
- GFTPUI_COMMON_COLOR_DEFAULT);
-