aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/kbear/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/kbear/Makefile')
-rw-r--r--ftp/kbear/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/ftp/kbear/Makefile b/ftp/kbear/Makefile
index 43017fba22ea..8e806b44f4b9 100644
--- a/ftp/kbear/Makefile
+++ b/ftp/kbear/Makefile
@@ -22,11 +22,10 @@ USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= XML2POT=${TRUE} PO2XML=${TRUE}
+CONFIGURE_ENV= XML2POT=${TRUE} PO2XML=${TRUE} LDFLAGS="${PTHREAD_LIBS}"
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>