aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/p5-Net-FTPSSL/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/p5-Net-FTPSSL/Makefile')
-rw-r--r--ftp/p5-Net-FTPSSL/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/ftp/p5-Net-FTPSSL/Makefile b/ftp/p5-Net-FTPSSL/Makefile
new file mode 100644
index 000000000000..2591291832b3
--- /dev/null
+++ b/ftp/p5-Net-FTPSSL/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-FTPSSL
+# Date created: 1st Dec, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-FTPSSL
+PORTVERSION= 0.16
+CATEGORIES= ftp perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A FTP over SSL/TLS class
+
+BUILD_DEPENDS= p5-IO-Socket-SSL>=1.08:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::FTPSSL.3
+
+.include <bsd.port.mk>