aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/proftpd/Makefile')
-rw-r--r--ftp/proftpd/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 00863adb9752..cb28a199e78b 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.0rc2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -50,16 +50,13 @@ OPTIONS= IPV6 "Use IPv6" off \
README "Include mod_readme" on \
RATIO "Include mod_ratio" on \
REWRITE "Include mod_rewrite" on \
- WRAP "Include mod_wrap" on
+ WRAP "Include mod_wrap" on \
+ RADIUS "Include mod_radius" off
MODULES?=
.include <bsd.port.pre.mk>
-.if defined(WITH_IFSESSION)
-MODULES:=${MODULES}:mod_ifsession
-.endif
-
.if defined(WITH_RATIO)
MODULES:=${MODULES}:mod_ratio
.endif
@@ -76,6 +73,10 @@ MODULES:=${MODULES}:mod_rewrite
MODULES:=${MODULES}:mod_wrap
.endif
+.if defined(WITH_RADIUS)
+MODULES:=${MODULES}:mod_radius
+.endif
+
.if defined(WITH_SETPASSENT)
CONFIGURE_ARGS+= --enable-force-setpassent
.endif
@@ -93,7 +94,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
#allow user to override
-MODULES?= mod_ifsession:mod_ratio:mod_readme:mod_rewrite:mod_wrap
+MODULES?= mod_ratio:mod_readme:mod_rewrite:mod_wrap:mod_ifsession
INCLUDEDIRS=
LIBDIRS=
@@ -145,6 +146,11 @@ MODULES:=${MODULES}:mod_quotatab_sql
.endif
.endif
+# mod_ifsession should be the last item in the modules list
+.if defined(WITH_IFSESSION)
+MODULES:=${MODULES}:mod_ifsession
+.endif
+
# Keep this here below, in case similar constructs need to be made
CONFIGURE_ENV+= "LIBS=${PROFTPD_LIBS}"