aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/proftpd
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile44
1 files changed, 41 insertions, 3 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 3ad3221d9132..f9f77f0d9070 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
PORTVERSION= 1.2.10
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
@@ -48,6 +48,42 @@ PLIST_SUB+= RC_DIR=${RC_DIR} \
CONFIGURE_ARGS= --localstatedir=/var/run \
--disable-sendfile
+OPTIONS= IPV6 "Use IPv6" off \
+ LDAP "Use LDAP" off \
+ MYSQL "Use MySQL" off \
+ POSTGRESQL "Use Postgres" off \
+ OPENSSL "Include mod_tls" off \
+ QUOTA "Include mod_quota" off \
+ IFSESSION "Include mod_ifsession" on \
+ README "Include mod_readme" on \
+ RATIO "Include mod_ratio" on \
+ REWRITE "Include mod_rewrite" on \
+ WRAP "Include mod_wrap" on
+
+MODULES?=
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_IFSESSION)
+MODULES:=${MODULES}:mod_ifsession
+.endif
+
+.if defined(WITH_RATIO)
+MODULES:=${MODULES}:mod_ratio
+.endif
+
+.if defined(WITH_README)
+MODULES:=${MODULES}:mod_readme
+.endif
+
+.if defined(WITH_REWRITE)
+MODULES:=${MODULES}:mod_rewrite
+.endif
+
+.if defined(WITH_WRAP)
+MODULES:=${MODULES}:mod_wrap
+.endif
+
.if defined(WITH_SETPASSENT)
CONFIGURE_ARGS+= --enable-force-setpassent
.endif
@@ -65,7 +101,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
#allow user to override
-MODULES?= mod_ratio:mod_readme:mod_wrap
+MODULES?= mod_ifsession:mod_ratio:mod_readme:mod_rewrite:mod_wrap
INCLUDEDIRS=
LIBDIRS=
@@ -134,6 +170,8 @@ CONFIGURE_ARGS+= --with-includes=${INCLUDEDIRS}
CONFIGURE_ARGS+= --with-libraries=${LIBDIRS}
.endif
+MODULES!=${ECHO} ${MODULES} | ${SED} -e 's,^:,,' -e 's,:$$,,'
+
pre-configure:
@${ECHO_MSG} "==> Configuring with ${MODULES}"
@@ -194,4 +232,4 @@ do-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
t/mail?h=gstreamer&id=33cc62296f9d9561cbb99693cf88035a26edaaf0'>Remove MySQL 4.1, it has been unsupported upstream for almost 3.5 years.flo2013-04-271-13/+4 * Update to 2.5.4.stefan2013-04-262-5/+5 * - Convert USE_GETTEXT to USES (part 4)ak2013-04-264-7/+4 * - Mark CONFLICTS among mail/libspf2, mail/p5-Mail-SPF and mail/p5-Mail-SPF-Qu...sunpoet2013-04-264-22/+13 * Fix a regression that had crept in with r314621. Do notsahil2013-04-265-5/+5 * Update to 1.4.31.novel2013-04-252-3/+3 * - Convert USE_GETTEXT to USES (part 3)ak2013-04-2551-51/+51 * - fix NOPORTDOCSjgh2013-04-253-22/+60 * For some unmaintained ports:eadler2013-04-252-10/+6 * - Fix ezmlm support by using subcommands of ezmlm-listbdrewery2013-04-243-3/+39 * - Convert USE_GETTEXT to USES (part 1)ak2013-04-244-8/+4 * - Update to 4.2.1ehaupt2013-04-244-22/+23 * Upgrade to new version 6.3.26.mandree2013-04-242-3/+3 * Finish converting the whole ports tree to USES=pkgconfigbapt2013-04-2310-31/+14 * Convert to USES=gettextehaupt2013-04-231-1/+1 * - Update to Postfix 2.11 Snapshot 20130405sahil2013-04-233-11/+14 * - Update to 2.8.14 and adjust CONFLICTSsahil2013-04-233-13/+17 * - Update to 2.7.13 and adjust CONFLICTSsahil2013-04-233-9/+15 * - Update to 2.6.19, update CONFLICTS and marksahil2013-04-232-5/+10 * Repo-copy mail/postfix -> mail/postfix29, and updatesahil2013-04-2313-12/+847 * Fix build with clang 3.3flo2013-04-232-0/+47 * - update to 8.14.7dinoex2013-04-232-3/+3 * Reassign skv@ ports to the heapbapt2013-04-223-18/+6 * Horde ports update:mm2013-04-228-12/+12 * Fix typo in GD_DESC.olgeni2013-04-21