aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/wget/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/wget/Makefile')
-rw-r--r--ftp/wget/Makefile52
1 files changed, 18 insertions, 34 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index b494086d2861..a5cfbfdf5dbb 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -15,6 +15,7 @@ LICENSE= GPLv3
USES= charsetfix gmake makeinfo perl5 tar:xz
USE_PERL5= build
GNU_CONFIGURE= yes
+OPTIONS_SUB= yes
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL=GNUTLS OPENSSL
@@ -23,6 +24,23 @@ OPTIONS_DEFAULT=OPENSSL IDN
PCRE_DESC= Support Perl regular expressions in addition to POSIX
+IPV6_CONFIGURE_ENABLE= ipv6
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
+
+IDN_USES= iconv
+IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
+IDN_CONFIGURE_ENABLE= iri
+IDN_CONFIGURE_ON= --with-libidn=${LOCALBASE}
+
+PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+PCRE_CPPFLAGS= -I${LOCALBASE}/include
+PCRE_LDFLAGS= -L${LOCALBASE}/lib
+PCRE_CONFIGURE_ENV_OFF= ac_cv_header_pcre_h=no
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
@@ -39,40 +57,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--without-ssl
.endif
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+=--enable-ipv6
-.else
-CONFIGURE_ARGS+=--disable-ipv6
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MIDN}
-LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
-CONFIGURE_ARGS+=--enable-iri --with-libidn=${LOCALBASE}
-USES+= iconv
-.else
-CONFIGURE_ARGS+=--disable-iri
-.endif
-
-.if ${PORT_OPTIONS:MPCRE}
-# Wget will pick pcre automatically and link with it if it is present.
-LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-CONFIGURE_ENV+= ac_cv_header_pcre_h=no
-.endif
-
INFO= wget
# eliminate gmakism