aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/yafc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/yafc/Makefile')
-rw-r--r--ftp/yafc/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index e055fa8a361d..2689ab664545 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= yafc
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.1
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,10 +15,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another ftp client. Similar to ftp(1)
USE_BZIP2= yes
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-socks4=no --with-socks5=no --with-krb4=no \
+ --with-krb5=no --with-gssapi=no
MAN1= yafc.1
INFO= yafc
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.sample ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>