aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile1
-rw-r--r--ftp/lftp/Makefile2
-rw-r--r--ftp/moftpd/Makefile6
-rw-r--r--ftp/wzdftpd/Makefile6
4 files changed, 8 insertions, 7 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 732bea073e60..848616511f4d 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= curl
PORTVERSION= 7.16.0
+PORTREVISION= 1
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
${MASTER_SITE_SOURCEFORGE} \
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index e0b8b60747bc..cd1319525859 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lftp
PORTVERSION= 3.5.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.wiretapped.net/pub/mirrors/lftp/ \
ftp://ftp.wiretapped.net/pub/mirrors/lftp/old/ \
diff --git a/ftp/moftpd/Makefile b/ftp/moftpd/Makefile
index 99c89875aee0..b39f9e669eb9 100644
--- a/ftp/moftpd/Makefile
+++ b/ftp/moftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= moftpd
PORTVERSION= 1.2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://ftp.morth.org/moftpd/ \
${MASTER_SITE_LOCAL}
@@ -31,7 +31,7 @@ RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
CONFIGURE_ARGS+= --without-tls
.elif defined(WITH_GNUTLS)
CONFIGURE_ARGS+= --without-openssl
-LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls
LIBS= -L${LOCALBASE}/lib -lgnutls
CFLAGS+= -I${LOCALBASE}/include
.else
@@ -48,7 +48,7 @@ CONFIGURE_ARGS+= --without-sql
post-patch:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/moftpd.sh > ${WRKDIR}/moftpd.sh
+ ${FILESDIR}/moftpd.sh > ${WRKDIR}/moftpd.sh
post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/moftpd.sh ${PREFIX}/etc/rc.d/
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 77d7750c8c42..677a3b33eadf 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wzdftpd
PORTVERSION= 0.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ COMMENT= Modular FTP server configurable online using SITE commands
USE_RC_SUBR= wzdftpd.sh
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME= pkgconfig
CONFIGURE_ARGS+= --without-pam --disable-pgsql --disable-bonjour --mandir=${MANPREFIX}/man
CONFIGURE_ENV= CPPFLAGS="${CPPLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
@@ -67,7 +67,7 @@ CONFIGURE_ARGS+= --disable-openssl
.endif
.if defined(WITH_GNUTLS)
-LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls
.else
CONFIGURE_ARGS+= --disable-gnutls
.endif