aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/py-requests-ftp/Makefile19
-rw-r--r--ftp/py-requests-ftp/distinfo3
-rw-r--r--ftp/py-requests-ftp/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index e12b6bb17fb4..6db91abfeefa 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -85,6 +85,7 @@
SUBDIR += py-ftputil
SUBDIR += py-pycurl
SUBDIR += py-pyftpdlib
+ SUBDIR += py-requests-ftp
SUBDIR += py-tftpy
SUBDIR += quftp
SUBDIR += rexx-curl
diff --git a/ftp/py-requests-ftp/Makefile b/ftp/py-requests-ftp/Makefile
new file mode 100644
index 000000000000..7a21b5bd742b
--- /dev/null
+++ b/ftp/py-requests-ftp/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= requests-ftp
+DISTVERSION= 0.3.1
+CATEGORIES= ftp python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= FreeBSD@Shaneware.biz
+COMMENT= Ftp transport adapter for requests
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/ftp/py-requests-ftp/distinfo b/ftp/py-requests-ftp/distinfo
new file mode 100644
index 000000000000..13e95d0b1090
--- /dev/null
+++ b/ftp/py-requests-ftp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519797133
+SHA256 (requests-ftp-0.3.1.tar.gz) = 7504ceb5cba8a5c0135ed738596820a78c5f2be92d79b29f96ba99b183d8057a
+SIZE (requests-ftp-0.3.1.tar.gz) = 7850
diff --git a/ftp/py-requests-ftp/pkg-descr b/ftp/py-requests-ftp/pkg-descr
new file mode 100644
index 000000000000..74a138f9ddd0
--- /dev/null
+++ b/ftp/py-requests-ftp/pkg-descr
@@ -0,0 +1,4 @@
+Requests-FTP is an implementation of a very stupid FTP transport
+adapter for use with the awesome Requests Python library.
+
+WWW: https://github.com/Lukasa/requests-ftp