aboutsummaryrefslogtreecommitdiffstats
path: root/games/54321/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/54321/Makefile')
-rw-r--r--games/54321/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/54321/Makefile b/games/54321/Makefile
index c65aeba9e4e4..5729355181fe 100644
--- a/games/54321/Makefile
+++ b/games/54321/Makefile
@@ -22,11 +22,15 @@ USE_SDL= image sdl
USE_GMAKE= yes
MAKEFILE= GNUmakefile
ALL_TARGET= all size
+USE_REINPLACE= yes
post-extract:
@${MKDIR} ${WRKSRC}/archs/FreeBSD
@${CP} ${FILESDIR}/variables.GNU ${WRKSRC}/archs/FreeBSD
+post-patch:
+ ${REINPLACE_CMD} -e "s,ARCH,OPSYS," ${WRKSRC}/GNUmakefile
+
post-build:
@${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/54321.sh > ${WRKSRC}/54321